Problem with SP2 evalution and target designer, cmi error 0x800a01c9


P

Paul Sucro

In target designer when I try to upgrade my SP1 .slx file to SP2,
I get the following error.


Configuration Managment Interface (CMI) Error Code 0x800a01c9
Description = (This is blank, so NO description)


And yes, I have upgraded the WSH to the latest version.

Any ideas.

Thanks,
Paul Sucro.
 
Ad

Advertisements

K

KM

Paul,

I am running here the latest XPe SP2 RC (the one that became Tech.Preview) and I coon't repro the issue.
If you'd like, you can send me your SLX files (put it in a zip) and I'll try it here to see if it is a special case with your
Configuration or not.

My email is konstmor At no_spam_hotmail . com

KM
 
P

Paul Sucro

I started with Embedded tools SP1, and added all Quick fixes and SP2
updates.
After this nothing work anymore. (It appears the Repository database
is corrupted.)
-----------------------------------
???? Whats wrong with SP2?????????
-----------------------------------

When I bring up Microsoft Component Designer, I get the following
error when clicking on the Package or Component Tab.
-------------------------------------------
Component Database Manager cannot retrieve data from the component
database.
For more information, please see the application event log.
---------------------------------------------------------------

After getting this warning/error, I found in the Event Viewer -
Application the following errors.

Source: MSSQLServer
Category: (8)
EventID: 19011
Description:
SuperSocket info: (SpnRegister) : Error 1355.

Also
Source: CMI
Category: None
EventID: 1
Description:
The CMI encountered the following error: 0x80042343 (-2147212477) A
Utilities method referenced a non-existent registry key or value.

\utilitiesc-1259
 
P

Paul Sucro

More information related to the error.

I've updated all the tools to SP2, including database engine.

------------------------------------

I start with SP1 release for target designer.
1. I delete the database.
2. I add all entries from SP1 to the database.
3. I add my local ".sld" files to the database.
--->>> At this point I start getting an error when picking
the Package or Compenent Tab in Component Database Manager. (See
below)
4. I add SP2 to the database.
5. I try to upgrade my SP1 ".slx" file to SP2.
---->>> I get the following error on every component
upgraded.
--------------------------------------------------
Info 101: Initializing new component: "Accessibility Core
[Version 5.1.2600, R620]"
Info 104: Upgrading from: "Accessibility Core [Version 5.1.2600,
R620]"
Warning 1119: Mismatched component revision during settings migration
for: "Accessibility Core [Version 5.1.2600, R620]"
Warning 1120: Service pack level mismatch. Disabling "Accessibility
Core [Version 5.1.2600, R620]."
Error 1120: Configuration needs to be upgraded. Service pack level
mismatch between current configuration and some components."
---------------------------------------------------
After this, the component is grayed out.

-----------------------------------------
Component Database Manager Error
-----------------------------------------
When clicking on the Package or Component Tab the following is
displayed
-----------------------------------------
Component Database Manager cannot retrieve data from the component
database.
For more information, please see the application log.
----------------------------------------------

The application log.
---------------------
Source: MSSQLServer
Category: (8)
EventID: 19011
Description:
SuperSocket info: (SpnRegister) : Error 1355.

Also
Source: CMI
Category: None
EventID: 1
Description:
The CMI encountered the following error: 0x80042343 (-2147212477) A
Utilities method referenced a non-existent registry key or value.

\utilitiesc-1259
------------------------

Whats wrong. I tried to add the registry key.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
Embedded\CMI\DBCmdTimeout
with a timeout of 5000. (No changes).
 
Ad

Advertisements

K

KM

Paul,

Just a suggestion.. Try using SmartUpgrade component that is part of the XPETools package on www.xpefiles.com (Development
Utilities/Main).
It may help you to properly upgrade all the components in your configuration.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top