problem with persian and arabic language in word 2007


R

Reza

Hi, since I installed Vista and Office/Word2007 on my PC a couple of months
ago,
I have been unable to type Farsi in Word. I never had any trouble with this
in XP.

I have, of course, installed Farsi in the language settings (input) and I
also have a large selection of Farsi fonts, which all display once Word is
opened. However, it does not matter which font I choose from the menu, it
just won't type! I can type Farsi in Wordpad, but not in Word (so it seems
that it is not the Vista settings, but some Office fault?).

Word opens/displays/reads docs in Farsi without any problems and shows the
font correctly, but e.g. editing these in Farsi is impossible.

I press the keys and nothing happens (tried both directions,
l-r and r-l)! I have no trouble typing in other languages and it is also
possible to insert Farsi letters by Insert>Symbol but this is of course not a
viable alternative for typing texts!
I tried uninstalling and reinstalling Persian in Windows Vista as well as in
the Office2007 Language Settings and it didn't help a bit. Have any ideas???

Also I tried the OSK and it didn't work out. No
letters were typed in the doc.

Same problem with arabic language instead of persian language.

The one solve i find is that i must press "Space" or "Enter" button before
pressing any character. but this is very hard to writing a long word file.

(I use vista home premium sp1 with Office enterprise 2007 updated)
 
Ad

Advertisements

P

Peter Jamieson

Here (English-language Vista + Office 2007) when I add the "Persian"
language in Vista Control Panel->Regional and Language options, I can choose
more than one keyboard, e.g. Persian, U.S., "Show more..."

To be able to type/edit Farsi characters in Word, I have to enable the
Persion language keyboard, then select it in the language bar (there is an
option for the Language, and another one for the Keyboard) when I am in
Word.

That's with Vista Ultimate - I do not know if exactly the same facilities
are in Vista Home, but I certainly hope so!
 
R

Reza

Peter Jamieson said:
Here (English-language Vista + Office 2007) when I add the "Persian"
language in Vista Control Panel->Regional and Language options, I can choose
more than one keyboard, e.g. Persian, U.S., "Show more..."

To be able to type/edit Farsi characters in Word, I have to enable the
Persion language keyboard, then select it in the language bar (there is an
option for the Language, and another one for the Keyboard) when I am in
Word.

That's with Vista Ultimate - I do not know if exactly the same facilities
are in Vista Home, but I certainly hope so!


Hi, i do all same you, but i have problem yet. i could type persian but
before typing any charecter i must to press "space" or "enter" button. and
this is so hard for typing or editing a long document.
 
G

grammatim

Are you the same person who asked the same question over the weekend?
Did you try the Urdu keyboard?

If not, then there are two people with the same problem and someone
has to find a way to tell Microsoft about it.
 
P

Peter Jamieson

I do not know what is different but here, it seems to work OK. The trouble
is that I do ot know what might cause this particular problem. None of the
language bar or Word Editing options that I can see seem relevant.

The main difference I can see from your message is that I do not select a
Farsi font (or any other font designed for right-to-left script). I am just
typing into a Normal paragraph, and the font display shows Arial (Body CS).
But it's difficult to believe that that would cause this problem.
 
G

grammatim

(And once you have your Arial Persian, you have no problem changing
the font to something you'd actually want to appear in your document.
Though my Arabic etc. default font is Tahoma, which has a very odd
Arabic appearance.)
 
Ad

Advertisements

R

Reza

the Eva is user that creat that topic, but i dont find her/his mail to ask
about solve. and i post reply on that topic.
 
R

Reza

i try with all fonts all many right-to-left languagees like
persian/arabic/ordu but there is problem yet.
do i can to restore word to default settings? this may help me. (i think
when i reinstall word, the setting not restore to default)
 
Ad

Advertisements

P

Peter Jamieson

(i think
when i reinstall word, the setting not restore to default)

That is correct. One thing that is not re-created is the "data key" in the
Windows registry. There is an article at

http://word.mvps.org/FAQs/Customization/DataKeySettings.htm

with more information about that, but it is rather old, and among other
things, you need to use

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Data

where it suggests

HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Data

Personally, I rename the Data key, accept that I will probably lose a lot of
settings, and go through the settings again when I remember.

You may also find that the "normal" template is not restored. I think you
will find information about that on the word.mvps.org site as well.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top