Problem with Pasting into Filtered Fields


G

golf2beach

I have filtered a worksheet which results in many rows being hidden.
When I select a cell to copy and then paste into the many visible cells I
cannot paste correctly. Excel will past the copied information into the
'hidden' cells as well. For example: I have a worksheet which contains data
in columns A-H and rows 1-25. When I envoke the Autofilter (which turns the
filters on for my header row) I filter the data so only the even numbered
rows are visible (the odd numbered rows are hidden). I then go to cell E2
and type in a value (replacing the value that was there). I then right mouse
click and copy the new value in cell E2. Now with the left mouse, I click on
cell E4 and highlight the visible cells in column E (E4, E6, E8, E10, E12,
E14, E16, E18, E20, E22 and E24). Once these cells are highlight I right
mouse click in the highligted area and select past. The new value is pasted
in those cells. Now when I turn off the filter (no rows are filtered) I
notice that the new value I orginally typed into cell E2 and pasted into the
other even number rows/cells is also pasted into the odd numbered rows/cells
as well. This is not the way Excel used to work for me. Two weeks ago when
I performed this function it would only paste the value in the even number
rows/cells and leave the filtered ones alone. Over the past eight years I
have performed this task numerious times each day without any problems until
about two weeks ago.

I am running Windows XP Professional. Version 5.1.2600 Service Pack 2 Build
2600. I'm running Microsoft Ovvice Excel 2003 (11.8211.8202) SP3.

Thanks for your assitance
 
Ad

Advertisements

M

Michael

Try this:
After selecting E2 and clicking on copy, select the filtered range where you
want to paste the information and before you hit paste, hit F5, the click on
the special cells button then select visible cells only and hit ok, you will
see the cells selected on your range and now do the pasting.
 
Ad

Advertisements

G

golf2beach

Thanks Michael for the information. Your work around works, but doesn't
quite answer my question. After trying your suggestion I noticed the step
that is causing the problem. Using the example I provided below the problem
occurs when I paste the copied information into the cells by clicking on the
Paste Value button on my toolbar rather than right mouse clicking in the
highlighted area and selecting paste. I put the Paste Value button on my
Toolbar by selecting View>Toolbars>Customize>then select the Edit in the
Catagories window>and then scroll down in the Commands window and select
Paste Value and drag and drop it to the Toolbar. That's the button that is
giving me the trouble. I swear it work the way I described below two weeks
ago, but now it doesn't. Oh well, at least I have a work around. Thanks
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top