Problem with installing .NET 1.1. on top of 2.0


M

mark4asp

I already have 2.0 Framework (and VS2005 + SP) on my PC.

I wanted to work throught the book "Test-Driven Development in Microsoft
..NET, Newirk & Vorontsov, 2004". I downloaded the source from the
author's site. It is an MSI. When I run the MSI it demands the Framework
version 1.1.4322 be installed.

"This setup requires the .NET Framework version 1.1.4322.
Please install the .NET Framework and run this setup again."

So I follow the link the the Microsoft site. Download their .NET
Framework 1.1 SDK (setup.exe, File version 1.1.4322.591, 108757 kb). I
run the setup. It forces me to run it twice in order to install all the
components.

Now I discover that I have two folders under
C:\WINDOWS\Microsoft.NET\Framework\,
there is a v1.1.4322 and a v1.0.3705.
v1.1.4322 only contains 2 files: (gacutil.exe.config,
regsvcs.exe.config)
v1.0.3705 has only 4 files (mscormmc.dll, installutil.exe.config,
mscormmc.cfg, regsvcs.exe.config)

I run the MSI again and it still gives me the message quoted above.

So it seems to me that the .net framework 1.1 can't be properly
installed if the 2.0 framework is already in place.

Is that the case? or have I made some huge mistake?
 
Ad

Advertisements

M

Michael Nemtsev, MVP

Hello mark4asp,

the mistake is that u downloaded SDK, not the .NET FW Redistributive

Btw,there is another simplier way. Just download MSI Editor (Orca from Windows
SDK) and remove the check for the FW -the key smth like "VsdLaunchConditions"

---
WBR,
Michael Nemtsev [.NET/C# MVP] :: blog: http://spaces.live.com/laflour

"The greatest danger for most of us is not that our aim is too high and we
miss it, but that it is too low and we reach it" (c) Michelangelo


m> I already have 2.0 Framework (and VS2005 + SP) on my PC.
m>
m> I wanted to work throught the book "Test-Driven Development in
m> Microsoft .NET, Newirk & Vorontsov, 2004". I downloaded the source
m> from the author's site. It is an MSI. When I run the MSI it demands
m> the Framework version 1.1.4322 be installed.
m>
m> "This setup requires the .NET Framework version 1.1.4322.
m> Please install the .NET Framework and run this setup again."
m> So I follow the link the the Microsoft site. Download their .NET
m> Framework 1.1 SDK (setup.exe, File version 1.1.4322.591, 108757 kb).
m> I run the setup. It forces me to run it twice in order to install all
m> the components.
m>
m> Now I discover that I have two folders under
m> C:\WINDOWS\Microsoft.NET\Framework\,
m> there is a v1.1.4322 and a v1.0.3705.
m> v1.1.4322 only contains 2 files: (gacutil.exe.config,
m> regsvcs.exe.config)
m> v1.0.3705 has only 4 files (mscormmc.dll, installutil.exe.config,
m> mscormmc.cfg, regsvcs.exe.config)
m> I run the MSI again and it still gives me the message quoted above.
m>
m> So it seems to me that the .net framework 1.1 can't be properly
m> installed if the 2.0 framework is already in place.
m>
m> Is that the case? or have I made some huge mistake?
m>
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top