Problem Adding XP/W2K client to W2K domain



This is going to be long. First of all, can I say that with the two systems
above, I don't need WINS?

I have 2 segments i.e. 25 & 26. My servers, DNS, DHCP WINS DC are all in
this segment. I can add client i.e. W2kpro & XP from segment 25 to DC at
segment 26. No problem. IP addresses for entire org are thru DHCP with WINS
config for win98/95 clients.

I have created a new DC in segment 25. One single machine with DNS,AD.
Everything is ok. Did nslookup from server and responds well. No errors in
Event log except for warning 5781 which says dynamic registration or
deregistration failed. Dynamic update for FLZ and RLZ are set to "Yes". SP 4
is on this server.

If i'm not mistaken, when a XP or W2K client is added to a domain, i speficy
the NETBIOS name of the Domain. This client should use DNS to locate the
necessary info to join the domain or does it still use Netbios/WINS??

The problem is I cannot add XP/w2k client on segment 25 to the new DC in
segment 25 but able to join DCs on segment 26. Error message states that
cannot find the NEtBIOS name or DNS SRV record error. Man, I have joined many
domains but this is weird.

The clients in segment 25 uses a DHCP relay ( on a W2k member server) to
acquire IP from DHCP which is in segment 26.

If the client and server is on the same segment, why can't it locate the DC
by broadcast. Furthermore, i have added the clients and this new DC as a WINS
client to my WINS server (check the entry, its there) in segment 26 and added
lmhost entries to the client with a #PRE & #DOM parameter and yet failed to
join. In addition to that, when I perform a nslookup from any client in
segment 25 to the new DC or to the DNS servers at segment 26, the query

Well since the DNS server is a DC, does it mean that non domain member
cannot even perform a nslookup query??

Any help would be appreciated.

Doug Sherman [MVP]

The server error indicates that the SRV records have not been registered.
This is why the client cannot find the domain controller when it points to
that server for DNS.

Try, restarting the Netlogon service on the server; reboot the workstation;
and again try to join the domain. See:;en-us;259277

Doug Sherman


Done that but no luck. I setup test DC in segment 25 as a comparison. I was
not able to join that domain too. But then, I brought it down to segment 26,
changed IP and everything necessary to eliminate errors. Then I tried to use
my workstation which is segment 26 to add the test DC. It worked. Why is

Doug Sherman [MVP]

Upon re-reading your initial post, I think the problem is in use of the
NetBIOS domain name. In Win2k and XP you do NOT use the NetBIOS name of an
AD domain to join the domain. Unless this is a single label AD domain, you
should use the full DNS domain name.

Doug Sherman

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question