Printer Queus--clearing


G

Guest

I'm running V64 and a Dell printer. The printer is shared with another
machine running XP. I have started a print job on the XP machine and it is
stuck in the queue in a deleting state:
@echo off
echo.
echo Purging the print queue . . .
net stop Spooler
echo Deleting all print jobs . . .
ping localhost -n 4 > nul
del /q \Windows\system32\spool\PRINTERS\*.*
net start Spooler
echo Done!
ping localhost -n 4 > nul
pause
I have tried running the script provided in other posts but even running as
an account with administrator privileges have not been able to remove the
job. I've run the script on the XP machine and in wht V64 machine. on the
V64 machine I get access denied in stopping and starting the spooler. Cannot
delete the spool files because they are in use.

What next?
 
Ad

Advertisements

G

Guest

Hustling,

When I've had the same problem where a deleting print job becomes stuck in
queue, I've resolved it by rebooting, sometimes several times before the
queue becomes cleared. While rebooting, I've also turned off the printer and
then back on again, sometimes several times before the stuck job clears
itself from the queue. Sometimes I had to employ variations of the above
approach, but eventually the stuck job cleared itself. I don't know anything
else to tell you, but the above approach has worked for me. However, it may
take persistence to getting the queue to clear. I usually have to use
variations of the above approach.

In addition, the following site specializes in print/printer issues. There
is a lot of information at the site, so you'll need to peruse it to determine
whether there is anything there that you can use:

http://www.coribright.com/windows/

Another approach is to search the Internet for solutions. Google is your
friend in that endeavor. If you get lucky, someone here may post a solution.
You never know.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top