Pivot Table field selection order


B

Bony Pony

Hi,
Using Excel 2007

For some reason my Pivot Table Field List selection under "Choose fields to
add to report:" is sorted in ascending order and not in the order they appear
in the data. This means that the data dates are sorted by month by year and
not by year by month.

e.g.
Sum of 1 Apr 2009
Sum of 1 Apr 2010
Sum of 1 Apr 2011
Sum of 1 Aug 2009
Sum of 1 Aug 2010
Sum of 1 Aug 2011
Sum of 1 Dec 2009
Sum of 1 Dec 2010
etc
instead of
Sum of 1 Apr 2009
Sum of 1 May 2009
Sum of 1 Jun 2009
etc.

This makes selecting contiguous months REALLY tedious!! What have I done??
Any suggestions appreciated!
Regards,
Bony
 
Ad

Advertisements

B

Bony Pony

Hi,
If you read the question you will see that the selection table is sorted not
the resulting table. Grouping works at a table level.
 
B

Bony Pony

Hi Herbert,
Great solution! I was interested to know how you access the PT Wizard in
2007 ??

While looking for it, I found the answer tomy own question.

In PivotTable Tools Ribbon under the Options Tab in the PivotTable section
where the PivotTable name is there is an Options tab. Click this, select
Options and then the Display Tab. At the bottom is a Field List option that
sorts the Source Data as you like it.

Thanks for the steer though!! Good tip for the future!

Best regards,
Bony
 
H

Herbert Seidenberg

Excel 2007
ALT+D+P
or
Customize Quick Access Toolbar >
PivotTable and PivotChart Wizard
 
Ad

Advertisements

Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top