Password problem


J

jimt

I'm using FP2000 with extensions 2002 (ver 5.0.2.6738) via sharepoint. I made
some changes and published a few weeks ago no problem.

Now when I try to do an open web I'm prompted for a name and password
"This operation requires author permission for localhost80."
I have not changed any FP or Admin settings. In the past the prompt only
occurs when publishing. I've tried the name and password I use for publishing
but the popup window refreshes with just the name still completed. The
localhost is located on the default C:\Inetput\wwwroot.

Because of a hard drive failure in Jan, I've since set a virtual site on an
external drive. When I do an open web on it with the publish name and
password the site opens fine. However looking at the virtual in IIS (5.1) the
localhost info is OK but the virtual has an Error-stop sign icon next to it.
If I click on the virtual in IIS the right window notes "There are no items
in this view". If I open web the virtual site the pages & directories are
listed fine.

I have purchased and installed MS-Expressions 2 and set up a different host
and account to make the migration eventually. From Expressions I have
imported the pages, directories, etc. from the localhost. When I open
Expressions it opens the expresssions site on problem no password prompt.

I'm at lost on why FP is now asking for a login. Equally I've tried about
every name and password combinations I've ever used for every apps/etc.

Any help, many thanks
Jim T.
 
Ad

Advertisements

J

jimt

Wierd! I went into IIS and right clicked on the default web site to get a
list of actions. I selected "Open with Frontpage" and the site opened without
a logon prompt window.

???
 
J

jimt

More symptoms. Opening FP and selecting open web. If you select localhost and
click on the OK button a popup window with a title of "Name and Password
Required". Under the title bar is a sentence of "This operation requires
author permission for localhost80." is displayed.

If instead you double click on the localhost in the open web popup window a
popup window with the title of "Enter Network Password". Below the title is
"Please enter your authentication information". The line below is "Resource
http://localhost". Then text boxes for "User Name" and "Password" and lastly
a check box to save this password in your password list.

I never use to get a logon prompt. I haven't change any setting in IIS nor
setting up a username and password.

As noted in the posting above; if I select the virtual site in the open web
window the Name and Password prompt appears. If I enter the Web Hosting name
(web site name/domain) and password (used to publish) the virtual site opens
OK. The same name and password for the localhost howerver does not work.

Totally lost... any help would be a lifesaver. Although I can open the
localhost via IIS, I'm reluctant to make any changes or publish using this
"back-door" workaround.

Thanks
Jim T.
 
R

Ronx

Have you installed IE7 or IE8 recently? If so, open Internet Explorer, then
Tools->Internet Options
Security Tab
Click "Trusted Sites"
Click Sites button
Clear the checkbox "Require server verification (https:) for all sites in
this zone"
In the text box "Add the website to the zone" type in http://127.0.0.1
Click Add
Click Close
Click OK


Note that the "virtual" site sounds like your hosted site on the internet.
The password set up for this site has nothing to do with localhost or your
PC.

--
Ron Symonds
Microsoft MVP (Expression)
http://www.rxs-enterprises.org/fp

Reply only to group - emails will be deleted unread.
 
J

jimt

I thought you nailed this one. I have auto-updates turn on and I did recently
(I think after the last time I worked on FP) OK the install of IE8. However,
I added "http://127.0.1.0" to the trusted sites. I tried open web again and
got the same "Name and Password Required" popup window. After verifying the
trusted site entry I did a window restart and tried again. Same results.

I have Spyware Terminator installed. It prompts to OK changes and during the
install I think I may have answered "No" to the first change (registry, dll,
?). Could this be the reason the trusted site doesn't work for me? (all the
trusted sites had the "requires authenticatin..." turn off).

Thanks for the help if you have additional suggestions I'd appreciate it and
try about anything.

Jim T.
 
Ad

Advertisements

J

jimt

Sorry my typo on the reply, I did enter http://127.0.0.1 and also my error
the check box is for verification not authentication (all are unchecked).

I took a look at the MS IE8 site and did some searches. Based on what I saw
I'm leaning to uninstall IE8.

Your thoughts?

Thanks
Jim T.
 
R

Ronx

I don't have a problem with IE8. But nowadays all my web sites are either
disc based, or hosted on a separet Windows 2003 server - I do not use
localhost or IIS on my PC.

When I did (with Windows XP Pro) there were no problems using IE7 or IE8
beta (as it was then).

The only other thing I can think of for your situation is running a server
health check.

Start->Administration Tasks->Microsoft SharePoint Administration
--
Ron Symonds
Microsoft MVP (Expression)
http://www.rxs-enterprises.org/fp

Reply only to group - emails will be deleted unread.
 
J

jimt

Thanks. I ran a health check in Sharepoint and received no errors other than
the usual "securtiy could be tightened" suggestion. The localhost is on my
laptop and is not accessible to other users. I do all of my FP work at home
and only do copy some databases to the PC at the town office (I do the
Access-2000 DB work also for the small town I live in, last year they voted
to double my salary, still $0).

Is there some security in IIS or other places that the install of IE8 may
have changed?

Thanks for all the help and quick replies.

Jim T.
 
J

jimt

I'm still dealing with a sudden and unexpected security popup window when
opening my default web in FP2000. I believe the "problem" occurred after an
automatic update to IE-8 (on my XP Pro system).

I didn't think the uninstall of IE8 would resolved the problem but I did the
uninstall anyway. It did not solve the problem.

The FP2000 is installed on my laptop and I have not set up any protection
(other
than XP user logon) since I'm the only one accessing the site and system. If
I start FP and do a file/open web a popup window comes up with a title bar of
"Name and Password Required", an information sentence of "This operation
requires author's permission for localhost80", "Name and Passwords are case
sensitive", followed by text entry boxes of "Name" and "Password".

I first tried every combination of name/passwords I've every used with no
luck getting past the popup window.

I posted this problem in the newsgroup and received a reponse to add
http://127.0.0.1 to the IE trusted sites. I've added this address and still
get the popup window.

If I go to IIS (5.1), select the default web, select actions/all tasks, and
then open with Front Page option the web site opens as expected. Under the
default properties for the web, on the Directory Security tab the "Anonymous
access" check box is check on (No user name/password required to access this
resource.). The User name is filled in with IUSR_"myname" (where "myname" is
my XP user name, the password field is greyed out with 10 dots/characters),
and the Allow IIS to control password check box set on. Lastly on the
Authentication Methods window the Basic authenticated access check box is off
while the Integrated Window authentication
check box is on.

I'm reluctant to use this method of opening the web versus directly by
opening the web through the launch of FP directly. I would like to turn the
popup window off (since I never use to get it) but as an alternative I would
"sign-in" each time I launch FP if I know or could set a name & password that
will work. Any idea of what name
and password is expected, where to look, where to set?

Any and all help/suggestions gratefully appreciated.

Thanks
Jim T.
 
Ad

Advertisements

J

jimt

Steve,

THANK YOU...THANK YOU...THANK YOU. I had added the local host to the trusted
sites. Per your suggestion I tried to add it to the local sites in IE (not
back to IE-7) and receive a message that it was in trusted and did I want to
move it to local. I answered yes and immediately went to FP and opened the
web with no problem.

Thanks again!
Jim T.
 
J

jimt

Last night I applied your fix with success! This morning my PC went through
an automatic update and "re-installed" IE8. After the install and reboot I
tried FP and the was able to get in without the logon popup window. Since the
install IE8 keeps the setting from the previous version, the localhost still
remained in the local sites.

Bottom line, FP-2000 will work with IE8 given the localhost is added to the
local sites.

Thanks again
Jim T.
 
T

Tom Willett

IE8 requires human intervention to allow it to install when it comes down
via updates.
--
Tom [Pepper] Willett
Microsoft MVP - FrontPage
---------------------------
: Last night I applied your fix with success! This morning my PC went
through
: an automatic update and "re-installed" IE8. After the install and reboot I
: tried FP and the was able to get in without the logon popup window. Since
the
: install IE8 keeps the setting from the previous version, the localhost
still
: remained in the local sites.
:
: Bottom line, FP-2000 will work with IE8 given the localhost is added to
the
: local sites.
:
: Thanks again
: Jim T.
:
:
: "Steve Easton" wrote:
:
: > I had the same issue after installing IE 8 and also after uninstalling.
: > I had to do a system restore to a date prior to the IE 8 install.
: >
: > However, try adding the site to the Local Intranet sites in IE.
: > I read somewhere that will work.
: >
: > --
: >
: > Steve Easton
: > Microsoft MVP FrontPage
: > FP Cleaner
: > http://www.95isalive.com/fixes/fpclean.htm
: > Hit Me FP
: > http://www.95isalive.com/fixes/HitMeFP.htm
: >
: >
: > : > > I'm still dealing with a sudden and unexpected security popup window
when
: > > opening my default web in FP2000. I believe the "problem" occurred
after an
: > > automatic update to IE-8 (on my XP Pro system).
: > >
: > > I didn't think the uninstall of IE8 would resolved the problem but I
did the
: > > uninstall anyway. It did not solve the problem.
: > >
: > > The FP2000 is installed on my laptop and I have not set up any
protection
: > > (other
: > > than XP user logon) since I'm the only one accessing the site and
system. If
: > > I start FP and do a file/open web a popup window comes up with a title
bar of
: > > "Name and Password Required", an information sentence of "This
operation
: > > requires author's permission for localhost80", "Name and Passwords are
case
: > > sensitive", followed by text entry boxes of "Name" and "Password".
: > >
: > > I first tried every combination of name/passwords I've every used with
no
: > > luck getting past the popup window.
: > >
: > > I posted this problem in the newsgroup and received a reponse to add
: > > http://127.0.0.1 to the IE trusted sites. I've added this address and
still
: > > get the popup window.
: > >
: > > If I go to IIS (5.1), select the default web, select actions/all
tasks, and
: > > then open with Front Page option the web site opens as expected. Under
the
: > > default properties for the web, on the Directory Security tab the
"Anonymous
: > > access" check box is check on (No user name/password required to
access this
: > > resource.). The User name is filled in with IUSR_"myname" (where
"myname" is
: > > my XP user name, the password field is greyed out with 10
dots/characters),
: > > and the Allow IIS to control password check box set on. Lastly on the
: > > Authentication Methods window the Basic authenticated access check box
is off
: > > while the Integrated Window authentication
: > > check box is on.
: > >
: > > I'm reluctant to use this method of opening the web versus directly by
: > > opening the web through the launch of FP directly. I would like to
turn the
: > > popup window off (since I never use to get it) but as an alternative I
would
: > > "sign-in" each time I launch FP if I know or could set a name &
password that
: > > will work. Any idea of what name
: > > and password is expected, where to look, where to set?
: > >
: > > Any and all help/suggestions gratefully appreciated.
: > >
: > > Thanks
: > > Jim T.
: > >
: > >
: > > "jimt" wrote:
: > >
: > >> I'm using FP2000 with extensions 2002 (ver 5.0.2.6738) via
sharepoint. I made
: > >> some changes and published a few weeks ago no problem.
: > >>
: > >> Now when I try to do an open web I'm prompted for a name and
password
: > >> "This operation requires author permission for localhost80."
: > >> I have not changed any FP or Admin settings. In the past the prompt
only
: > >> occurs when publishing. I've tried the name and password I use for
publishing
: > >> but the popup window refreshes with just the name still completed.
The
: > >> localhost is located on the default C:\Inetput\wwwroot.
: > >>
: > >> Because of a hard drive failure in Jan, I've since set a virtual site
on an
: > >> external drive. When I do an open web on it with the publish name and
: > >> password the site opens fine. However looking at the virtual in IIS
(5.1) the
: > >> localhost info is OK but the virtual has an Error-stop sign icon next
to it.
: > >> If I click on the virtual in IIS the right window notes "There are no
items
: > >> in this view". If I open web the virtual site the pages & directories
are
: > >> listed fine.
: > >>
: > >> I have purchased and installed MS-Expressions 2 and set up a
different host
: > >> and account to make the migration eventually. From Expressions I have
: > >> imported the pages, directories, etc. from the localhost. When I open
: > >> Expressions it opens the expresssions site on problem no password
prompt.
: > >>
: > >> I'm at lost on why FP is now asking for a login. Equally I've tried
about
: > >> every name and password combinations I've ever used for every
apps/etc.
: > >>
: > >> Any help, many thanks
: > >> Jim T.
: >
: >
: >
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top