Outlook VBA Macro not loading on startup


F

Francesco Sandri

Hi,
recently I upgrade Office from 2007 to 2010. I use a macro that loads on startup, for archiving mails.

After upgrade, it seems, the entire Macro system on Outlook doesn't load on the program startup.
The security notify shows up only when I launch VBA Editor (Alt+F11).

The macro works fine with others Office 2010. Mine too.

I tried changing macro security, re-creating outlook profile, using another user and re-installing Office 2010.

I also triend with a simple msgbox macro on subroutine Application_Startup() but nothing works.

What can I do? With Outlook seems to check for macros only when I go to the VBA Editor?

Many thanks.

Francesco Sandri
 
Ad

Advertisements

G

Graham Mayor

Oddly enough, I have just re-installed Windows on a PC with Office 2007 and
today had this same issue.
In the Office folder you will find selfcert.exe which will enable you to
create a certificate for your own macros.
Having done that, set the macro security in Outlook to provide warnings for
all macros
Then start the VBA editor and from Tools > Digital Signatures, add your
newly created signature to the project.
Close Outlook saving the project at the warning.
Re-open Outlook and you will get a security prompt for the vbaproject. From
that dialog choose the option to trust items from the publisher (your
certificate).
Thereafter the macros should work normally without the prompts.

--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP

My web site www.gmayor.com

<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
 
G

Graham Mayor

"Re-open Outlook and you will get a security prompt for the vbaproject."
should have read 'Re-open Outlook then access the vba editor and you will
get a security prompt etc ....'

--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP

My web site www.gmayor.com

<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
 
F

Francesco Sandri

How is it possible that it works as is for other five PCs and with this doesn't?

It seems that the entire Macro system wake up only when I open VBA Editor.
The security notify appears only when I open that.

Is there a way to check Outlook components boot order? Or a way to find out with macros don't start on Outlook opening?

Thank you
Francesco
 
Ad

Advertisements

G

Graham Mayor

The short answer is I don't know. Maybe it is the result of a security
update. I didn't have the issue before I re-installed Windows and Office.
However creating a self certificate and applying it to the vba project
should fix it.

--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP

My web site www.gmayor.com

<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top