Outlook 2003 spell check w/ Mark My Comments With enabled


D

Don Powell

When using "Mark My Comments With" the editor automatically inserts [my
username] as it should with no space in front of the insertion. If I'm using
Word as my editor and run a spell check it thinks that I've misspelled
because the inserted [username] is directly behind the word I added it to (no
space). But If I'm using the built in Outlook editor then spell check it
correctly recognizes that the Mark My Comments With insert is not part of the
word it's connected to. Is there a way to fix this?
 
Ad

Advertisements

V

VanguardLH

Don said:
When using "Mark My Comments With" the editor automatically inserts [my
username] as it should with no space in front of the insertion. If I'm using
Word as my editor and run a spell check it thinks that I've misspelled
because the inserted [username] is directly behind the word I added it to (no
space). But If I'm using the built in Outlook editor then spell check it
correctly recognizes that the Mark My Comments With insert is not part of the
word it's connected to. Is there a way to fix this?

Why not add your name to the custom dictionary. Just select to Add your
name when next the spelling checker hits it. Or is the problem you mean to
report is that Word doesn't parse "string[yourname]" as two strings so it
thinks it is a misspelling on one string? Wouldn't the lack of an
intervening space be due to you not adding one? I'm pretty sure the spell
checker works on word boundaries, not on substrings within a word.

Maybe using tracking of changes in Word docs (Tools -> Tracking) would work
better to determine just what got changed, especially if you are going to
show edits for substrings rather than on word boundaries.

Since this is an issue with Word's spell checker, your question is more
appropriate for a Word newsgroup to discuss the behavior of that program.
You'll find more Word wizards in a Word newsgroup or forum than are here.
 
D

Don Powell

VanguardLH said:
Don said:
When using "Mark My Comments With" the editor automatically inserts [my
username] as it should with no space in front of the insertion. If I'm using
Word as my editor and run a spell check it thinks that I've misspelled
because the inserted [username] is directly behind the word I added it to (no
space). But If I'm using the built in Outlook editor then spell check it
correctly recognizes that the Mark My Comments With insert is not part of the
word it's connected to. Is there a way to fix this?

Why not add your name to the custom dictionary. Just select to Add your
name when next the spelling checker hits it. Or is the problem you mean to
report is that Word doesn't parse "string[yourname]" as two strings so it
thinks it is a misspelling on one string? Wouldn't the lack of an
intervening space be due to you not adding one? I'm pretty sure the spell
checker works on word boundaries, not on substrings within a word.

Maybe using tracking of changes in Word docs (Tools -> Tracking) would work
better to determine just what got changed, especially if you are going to
show edits for substrings rather than on word boundaries.

Since this is an issue with Word's spell checker, your question is more
appropriate for a Word newsgroup to discuss the behavior of that program.
You'll find more Word wizards in a Word newsgroup or forum than are here.
.
 
D

Don Powell

Yes, the problem is that Word doesn't parse "string[yourname]" as two strings
so it detects a misspell. There's no way to add a space at the beginning of
the string as it is an Outlook option that you put a checkmark in, no options
for anything other that [your name]. The builtin Outlook editor/ spell check
recognizes it properly as does Outlook 2007 but using Word 2003 as the
default editor for Outlook has the issue.

The reason I didn't post this in a Word newsgroup is that I guessed that
Outlook users would run into it rather than Word users. It seems logical to
me that a spell check should in fact consider it a misspell but somehow the
Outlook spell check knows the distinction.

VanguardLH said:
Don said:
When using "Mark My Comments With" the editor automatically inserts [my
username] as it should with no space in front of the insertion. If I'm using
Word as my editor and run a spell check it thinks that I've misspelled
because the inserted [username] is directly behind the word I added it to (no
space). But If I'm using the built in Outlook editor then spell check it
correctly recognizes that the Mark My Comments With insert is not part of the
word it's connected to. Is there a way to fix this?

Why not add your name to the custom dictionary. Just select to Add your
name when next the spelling checker hits it. Or is the problem you mean to
report is that Word doesn't parse "string[yourname]" as two strings so it
thinks it is a misspelling on one string? Wouldn't the lack of an
intervening space be due to you not adding one? I'm pretty sure the spell
checker works on word boundaries, not on substrings within a word.

Maybe using tracking of changes in Word docs (Tools -> Tracking) would work
better to determine just what got changed, especially if you are going to
show edits for substrings rather than on word boundaries.

Since this is an issue with Word's spell checker, your question is more
appropriate for a Word newsgroup to discuss the behavior of that program.
You'll find more Word wizards in a Word newsgroup or forum than are here.
.
 
V

VanguardLH

Don said:
The reason I didn't post this in a Word newsgroup is that I guessed that
Outlook users would run into it rather than Word users. It seems logical to
me that a spell check should in fact consider it a misspell but somehow the
Outlook spell check knows the distinction.

I did some testing (normally I do not use Word as my new-mail editor and
instead use the embedded editor in Outlook 2003). It is not a spelling
error that gets caught when you add an inline comment inline with no leading
whitespace within a sentence. It is a grammar error that is caught. Well,
"this sentence.[yourname] more text" is obviously a grammar error. If I
configure Outlook to use Word to compose e-mails and if I disable the
grammar checking in Word then I get no error for "some text in doc.[myname]
comment here". Outlook only has a spell checker, no grammar checker. This
is true up to version 2003 of Outlook which had its own embedded new-mail
editor. As of version 2007, you are forced to use Word as the new-mail
editor which means you would then get both the spelling and grammar
checkers.

Pre-2007 versions: Just a spelling checker in Outlook, no grammar checker.
A grammar checker available if you configure Outlook to use Word as the
new-mail editor.

2007+ versions: Spelling and grammar checkers are both available since you
are forced to use Word as the new-mail editor.

When you insert a comment inline (inside a sentence) then you already can
position your comment to start after some whitespace that already exists
within that sentence, like after a space or tab character. It is when you
want to add a comment at the end of a line where there is normally no
whitespace there to push out your inline comment. However, since the "Mark
my comments with" option only works when using HTML or RTF to format your
e-mails and because the only place in those documents where there is no
whitespace after a word is at the end of a paragraph then there is only one
spot where this causes a problem: adding a comment at the end of a
paragraph. For HTML e-mails, there is no end of line since it wraps at
whatever is the current width of the window. You would be placing the
insert point at the start of the next word to insert your inline comment
(which might mean placing the insert point at the start of the first word in
the line drawn line for the current window width). Within the paragraph
there would always be some whitespace so the insert point would be at the
start of the next word. However, you are expected to add a space at the end
of your inline comment to provide proper parsing from the last word in your
comment to the next word in the original document.

If you use the Ctrl+[left|right]arrow to position the insert point then you
are guaranteed to be at a spot where your inline comment will have a leading
space (because it came from the original document). It's just at the end of
the paragraph where there may be no trailing whitespace to use to separate
your comment from the original text. However, if you are adding a comment
at the end of a paragraph (whether 1 or several lines make up that
paragraph) then it makes sense to just hit the Enter key to start you
comment on a new line. After all, your "inline" comment comes at the end of
the paragraph so it probably addresses that entire paragraph.

If you don't have a leading space before your inline comment then it is
because of where you chose to pick the insert point. Don't point at the end
of a word. Point to the start of the next word. For comments added after a
paragraph, you probably should start the comment on a new line. This style
change isn't just to make the spelling checker work. It is also to make it
easier for your recipients of your modified document be able to see where
you inserted your comments. Their "reading eye" should catch your comments
due to not only their coloring but also due to whitespacing.
 
Ad

Advertisements

D

Don Powell

I don't know how you figured this one out but you're absolutely correct.

Thanks a mill for taking the time to help me out. I'd never have figured it
out by myself!

VanguardLH said:
Don said:
The reason I didn't post this in a Word newsgroup is that I guessed that
Outlook users would run into it rather than Word users. It seems logical to
me that a spell check should in fact consider it a misspell but somehow the
Outlook spell check knows the distinction.

I did some testing (normally I do not use Word as my new-mail editor and
instead use the embedded editor in Outlook 2003). It is not a spelling
error that gets caught when you add an inline comment inline with no leading
whitespace within a sentence. It is a grammar error that is caught. Well,
"this sentence.[yourname] more text" is obviously a grammar error. If I
configure Outlook to use Word to compose e-mails and if I disable the
grammar checking in Word then I get no error for "some text in doc.[myname]
comment here". Outlook only has a spell checker, no grammar checker. This
is true up to version 2003 of Outlook which had its own embedded new-mail
editor. As of version 2007, you are forced to use Word as the new-mail
editor which means you would then get both the spelling and grammar
checkers.

Pre-2007 versions: Just a spelling checker in Outlook, no grammar checker.
A grammar checker available if you configure Outlook to use Word as the
new-mail editor.

2007+ versions: Spelling and grammar checkers are both available since you
are forced to use Word as the new-mail editor.

When you insert a comment inline (inside a sentence) then you already can
position your comment to start after some whitespace that already exists
within that sentence, like after a space or tab character. It is when you
want to add a comment at the end of a line where there is normally no
whitespace there to push out your inline comment. However, since the "Mark
my comments with" option only works when using HTML or RTF to format your
e-mails and because the only place in those documents where there is no
whitespace after a word is at the end of a paragraph then there is only one
spot where this causes a problem: adding a comment at the end of a
paragraph. For HTML e-mails, there is no end of line since it wraps at
whatever is the current width of the window. You would be placing the
insert point at the start of the next word to insert your inline comment
(which might mean placing the insert point at the start of the first word in
the line drawn line for the current window width). Within the paragraph
there would always be some whitespace so the insert point would be at the
start of the next word. However, you are expected to add a space at the end
of your inline comment to provide proper parsing from the last word in your
comment to the next word in the original document.

If you use the Ctrl+[left|right]arrow to position the insert point then you
are guaranteed to be at a spot where your inline comment will have a leading
space (because it came from the original document). It's just at the end of
the paragraph where there may be no trailing whitespace to use to separate
your comment from the original text. However, if you are adding a comment
at the end of a paragraph (whether 1 or several lines make up that
paragraph) then it makes sense to just hit the Enter key to start you
comment on a new line. After all, your "inline" comment comes at the end of
the paragraph so it probably addresses that entire paragraph.

If you don't have a leading space before your inline comment then it is
because of where you chose to pick the insert point. Don't point at the end
of a word. Point to the start of the next word. For comments added after a
paragraph, you probably should start the comment on a new line. This style
change isn't just to make the spelling checker work. It is also to make it
easier for your recipients of your modified document be able to see where
you inserted your comments. Their "reading eye" should catch your comments
due to not only their coloring but also due to whitespacing.
.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top