Office 2003 error in limited accounts...stdole32.tlb


R

randolindso

I'm running Windows XP Home with one Admin account and two Limited accounts.
I've had Office 2003 Professional installed for years with no problems. I
decided to install all the updates through Microsoft update...did so, and now
it throws an error when trying to run any Office progs in the limited
accounts. Each time I run them it trys to run an installer. One time only
it gave an error for stdole32.tlb. The Office progs run fine when the user
is changed to Admin. I've tried uninstalling and reinstalling. I've tried
temporarily changing the accounts to Admin before installing. I've tried
running the Office progs once under Admin and then changing back to Limited.
I'm pretty sure it's a permissions problem, possibly involving
stdole32.tlb....Any ideas?
 
Ad

Advertisements

R

randolindso

Thanks for your reply, but it did not make any difference. Office still will
not run correctly under the limited accounts. I've read some about changing
permissions in certain registry keys. Any thoughts on that? And which keys?
Also, any ideas concerning the ole file?
 
R

randolindso

Thanks for the response. Unfortunately, it did not work. I also tried
KB265194 method 2...no luck with it either. Any other ideas?
 
R

randolindso

I read your last response- you asked if office progs worked in elevated mode-
for some reason now your thread is missing - but my reply is "how do I run a
program, for instance Word, in elevated mode?" It's not the same as "RunAs,
is it?
 
Ad

Advertisements

R

randolindso

For some reason my replies aren't getting through but I did receive your
response about elevating the programs in the limited accounts. I guess I'm
not sure what you mean by elevating? Is it the same as RunAs? I've tried to
do RunAs but there is no option in right-click and in the advanced properties
for each shortcut the Run with Different Credentials is grayed out.
 
Ad

Advertisements

R

randolindso

Thanks for the tip on the newsreader. And, the problem in XP Home and Office
2003 after installing Office SP3 has been resolved. After three weeks of
searching and two sessions with Microsoft Update Support (in which I was
very, very disappointed- after more than an hour on the phone with them two
different times I was told to just change all user accounts from limited to
admin) I found a website with a fix. My sincere thanks go out to Andy at
that site and a reader of his, Brian. Brian's fix was a subinacl routine
for Office permissions errors in Vista but I was out of ideas so I tried it
on my XP Home- it worked beautifully. For all those users out there with the
same problem (Windows Installer runs over and over when opening Office progs,
Excel throws "stdole32.tlb' error)....Try this link (It says it's a fix for
Vista and Office 2007, but , as I said, it works on XP Home and Office 2003
too...and, I would suspect, XP Pro):
http://dventhusiast.com/problems/vista-office-2007-installation-problems-stdole32tlb/
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top