nVidia GT 520 rendered onbord sound card useless?


B

Bubba

Greetings to all,

the machine in question is HP dc5850 (Phenom X4, 8GB RAM, Windows 7 x64)
machine that had Quadro NVS 285 card inside. Due to some requirements,
machine had to be equipped with CUDA capable dual monitor LP card. Since
price *did* matter, I obtained 70$ worth PoV GT 520 card and HDMI->DVI
adapter.

The moment I inserted the card, I lost onboard Realtek HDA and got two
"Digital Audio (HDMI)" playback devices.

http://tinypic.com/r/6z90g7/7
http://tinypic.com/r/2lk7ig2/7

I tried multiple solutions (changing drivers, various hacks for disabling
HDMI Audio, etc.) but nothing helped.

Apparently, there should be an option to disable audio but I seem to have
none on my card.

http://tinypic.com/r/1498qk8/7

Any help is appreciated.

TIA!
 
Ad

Advertisements

G

GMAN

Greetings to all,

the machine in question is HP dc5850 (Phenom X4, 8GB RAM, Windows 7 x64)
machine that had Quadro NVS 285 card inside. Due to some requirements,
machine had to be equipped with CUDA capable dual monitor LP card. Since
price *did* matter, I obtained 70$ worth PoV GT 520 card and HDMI->DVI
adapter.

The moment I inserted the card, I lost onboard Realtek HDA and got two
"Digital Audio (HDMI)" playback devices.

http://tinypic.com/r/6z90g7/7
http://tinypic.com/r/2lk7ig2/7

I tried multiple solutions (changing drivers, various hacks for disabling
HDMI Audio, etc.) but nothing helped.

Apparently, there should be an option to disable audio but I seem to have
none on my card.

http://tinypic.com/r/1498qk8/7

Any help is appreciated.

TIA!

Go to Control Panel, Sound and Audio Devices, then Audio properties tab, then
choose your default playback device.
 
P

Paul

Bubba said:
GMAN's log on stardate 15 srp 2011


I gave you the exact screenshot of that tab and it consists of (nVidia)
HDMI Audio devices only.

http://tinypic.com/r/2lk7ig2/7

Have you tried looking in Windows/inf/setupapi.dev.log ?

It looks like a record of the installation of hardware devices.

I don't know if a separate error log is kept anywhere.
Event Viewer would be a traditional place to look, but
I never seem to see anything interesting in there.

I looked at both a RealTek driver package and a
freshly downloaded NVidia one for a GT520 for x64, and
both of them use proper VEN and DEV codes. Nvidia
VEN is 10DE and RealTek is 10EC. So it's probably
not direct interference of one driver installer
with the other.

In Device Manager, you have options such as
"Roll Back Driver" if you just installed a
driver off the Nvidia CD. (Roll Back only
works to one level, so isn't likely to
work a year from now.)

Another option would be to "Disable Device" in
Device Manager and get rid of the Nvidia that way.
Then try reinstalling the RealTek.

I had two sound devices under WinXP, and had one
of them, "shoot the other one in the foot". There was
a registry setting that one sound device checked
for, and the other one wrote a bogus value in
the registry entry. Once I found it using
sysinternals.com procmon, I could correct it
such that both sound devices would work. The
installer for the failing sound device, would
not write the registry for that key, but
the software did check for it later. It was intended
to make the first driver "defer" to the second one.
But once I discovered which registry value it was,
I could set it up so both hardware drivers worked,
and I could select either one as the output.

http://technet.microsoft.com/en-us/sysinternals/bb896645

You don't really want to do that, but that's an example
of how much trouble you can go to, to fix the sound.
Watching filtered registry reads, with Process Monitor.
And noticing "mixer.exe" dies, after a certain
registry entry is checked.

Paul
 
B

Bubba

Paul's log on stardate 15 srp 2011
Have you tried looking in Windows/inf/setupapi.dev.log ?

Never knew this one existed. Great tip. Unfortunately...
It looks like a record of the installation of hardware devices.

....it doesn't shed any light on my problem.

/snip

I was really frustrated, so I took a whole day and this is what happened -
it seems that (I *really* don't know how) by putting GT 520 to PCI-E slot
onboard Audio gets disabled in *BIOS*. Reenabling it does not help,
however, this is how I did it:

i) removed GT 520 and started Windows with onboard ATI card
ii) removed all drivers
iii) reenabled onboard Audio in BIOS
iv) reinstalled Realtek drivers
v) returned GT 520
vi) enabled onboard Audio in BIOS once again

Now it works. Huh?

Anyhow, thank for your time! Have a nice weekend!¸
 
P

Paul

Bubba said:
Paul's log on stardate 15 srp 2011


Never knew this one existed. Great tip. Unfortunately...


...it doesn't shed any light on my problem.

/snip

I was really frustrated, so I took a whole day and this is what happened -
it seems that (I *really* don't know how) by putting GT 520 to PCI-E slot
onboard Audio gets disabled in *BIOS*. Reenabling it does not help,
however, this is how I did it:

i) removed GT 520 and started Windows with onboard ATI card
ii) removed all drivers
iii) reenabled onboard Audio in BIOS
iv) reinstalled Realtek drivers
v) returned GT 520
vi) enabled onboard Audio in BIOS once again

Now it works. Huh?

Anyhow, thank for your time! Have a nice weekend!¸

" by putting GT 520 to PCI-E slot onboard Audio gets disabled in *BIOS* "

Well, that's a new one.

Thanks for reporting back :)

The BIOS shouldn't really do that, but then, the BIOS used
to do stuff like that for video in some cases (installing
an add-in video device would disable another, when they really
all could have been left running).

If the BIOS was consistent, you'd think it would also
disable your onboard ATI as well.

Paul
 
Ad

Advertisements

Joined
May 15, 2012
Messages
1
Reaction score
0
Another I'm not sure how but it's fixed. At least no uninstall was involved. I installed a PNY Nvidia Quadro 600 in my Dell 5400 w/o Nvidia HD Audio Driver and it disabled my onboard (and only) sound. BIOS (which was up to date) showed only Nvidia & was display only. After installing HD Audio Driver, Nvidia Ctrl Panel at least showed an audio setting, though only HD. Left a message with PNY. Next day updated Quadro driver though Windows. Further updated Quadro driver through Nvidia examining my PC. BIOS now showed my onboard sound and I switched from "auto" to "on." Never thought I'd be so happy to hear the Win 7 jingle.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top