no custom button in ribbon


B

Birgit

Dear all,

I am working on 2 buttons in the ribbon of Excel 2007 (on Vista). I manage
to put the button into the OfficeMenu but the button on the homeTab will not
show up. I can not find a problem with the XML. The button on the homeTab is
supposed to be placed in front of the group clipboard.

I have looked around to find a solution to this problem, but to no avail.
Does anyone have a suggestion, please?

XML follows:
----------------------
<customUI xmlns="http://schemas.microsoft.com/office/2006/01/customui">
<ribbon>
<officeMenu>
<button id="testMenuButtonI" label="De test standaard Excel"
insertAfterMso="FileNew" imageMso="MailMergeStartLetters" screentip="De test
standaard" supertip="Maak een nieuwe standaardwerkmap."
onAction="StartStandaardExcel" />
</officeMenu>

<tabs>
<tab id="TabHome">
<group id="customGroup" label="De test"
insertBeforeMso="GroupClipboard">
<button id="customExcelStandaard" label="Start"
imageMso="MailMergeStartLetters" size="large" screentip="De test standaard"
supertip="Maak een nieuwe standaardwerkmap." onAction="StartStandaardExcel"
/>
</group>
</tab>
</tabs>
</ribbon>
</customUI>
 
Ad

Advertisements

I

ilia

Birgit,

Change this line:

<tab id="TabHome">

To this:

<tab idMso="TabHome">

See if that makes a difference.

-Ilia
 
Ad

Advertisements

B

Birgit

Thank you very much for your help Ilia and Ron,

The tip with IdMso worked like a charm (Is this again the small differences
we have always seen between Word and Excel?).

Ron, you have a great website. I have put it into my favorites to return to
it soon.

Cheers,
Birgit
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top