Network Bridge woes


B

Broady

Hi all,
I'm having problems getting the network bridge option in windows xp to work
correctly.

PC 1: Wireless (static ip 192.168.0.21 255.255.255.0) connects to wireless
router (static 192.168.0.11 - which in turn connects to ADSL router
192.168.0.10). This configuration works fine and I have no problem
connecting to the Internet. This PC also has a wired connection with a
static ip address of 192.167.0.10 mask 255.255.255.0

PC 2: Wired connection only with a static ip of 192.167.0.11 mask
255.255.255.0. The wired network works correctly. I want this pc to be able
to access the Internet using the others' wireless connection, i.e. using PC
1 as a bridge.

I initially had the problem that the wireless connection stopped working
when joined to the bridge but I solved this by manually forcing
compatibility mode. What happens now however is when the bridge is created
it has an ip address of 0.0.0.0 (I have no DHCP) and consequently there is
no connectivity from the bridge. I have manually assigned an IP address to
the bridge and all three connections show as 'connected' in the network
connections. BUT, no matter what IP adress I give the bridge, I receive a
windows system error that there is a duplicate ip address on the network as
soon as I try to use the internet! There are no other machines on the
network so there definitely isnt a conflict and I'm at a loss as to what is
happening here. I have so far tried about a dozen different ip addresses but
always with the same result.

ANy help would be greatly appreciated!

Cheers,
Steve

remove spamtrap when replying by email.
 
Ad

Advertisements

D

Doug Sherman [MVP]

Assuming that your router supports static routes, this is a straight forward
routing problem and bridging connections on PC1 is not going to solve it.

Try:

1. Configure a static route on your router for the 192.167.0.x network with
a gateway of 192.168.0.21. You will have to consult the router manual to
determine how to do this.

2. On PC1 get rid of the bridge and enable routing:

Start/Run regedit ENTER. Navigate to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Double click on IPEnableRouter and set its value to 1.

3. On PC2 configure 192.167.0.10 as the default gateway, and enter the IP
address of your ISP's DNS server for primary DNS.

Doug Sherman
MCSE, MCSA, MCP+I, MVP
 
B

Broady

Doug Sherman said:
Assuming that your router supports static routes, this is a straight
forward
routing problem and bridging connections on PC1 is not going to solve it.

Try:

1. Configure a static route on your router for the 192.167.0.x network
with
a gateway of 192.168.0.21. You will have to consult the router manual to
determine how to do this.

Doh! I'd already configured routing before I'd tried bridging but I totally
forgot the router would need a route too.

Thanks a lot, this solved the problem :)

Steve
 
Ad

Advertisements

D

Doug Sherman [MVP]

Thanks for the feed back - go get 'em.

Doug Sherman
MCSE, MCSA, MCP+I, MVP
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top