multiple NICs


G

Guest

I have two computers at home, each connected to the internet and each other
thru a wired router. Each computer has two NICs, one each with full access
to both the local network and the internet, and one each with access only to
the local network. All NICs use static IP addresses. The NICs with only
local access use the same IP range, same gateway, and same DNS as the other
NICs, but the router is configured to block all access to and from the
internet for the local IP addresses.

Here is the trouble I am having. When I am not using the internet, I
disable that NIC for a little extra security. But when the internet NIC is
re-enabled is comes up as "Local Access Only" and cannot access the internet.
If I disable both NICs and re-enable the internet NIC first, then all is
good. This is annoying because I leave the computer on with the local NIC on
so the other computer can access the files, but if I want to come and use the
internet, then I have to disable the local NIC, enable the internet NIC, then
when I'm done with the internet I have to disable the internet NIC and
re-enable the local NIC. Other computer is XP and this setup works great on
it.

Sorry for the long post, but I try to be thorough. Any help would be deeply
appreciated.
 
Ad

Advertisements

R

Robert L [MVP - Networking]

Is it possible you have two default gateways. Post back with the result of ipconfig /all when you have both NICs enabled.

Bob Lin, MS-MVP, MCSE & CNE
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
I have two computers at home, each connected to the internet and each other
thru a wired router. Each computer has two NICs, one each with full access
to both the local network and the internet, and one each with access only to
the local network. All NICs use static IP addresses. The NICs with only
local access use the same IP range, same gateway, and same DNS as the other
NICs, but the router is configured to block all access to and from the
internet for the local IP addresses.

Here is the trouble I am having. When I am not using the internet, I
disable that NIC for a little extra security. But when the internet NIC is
re-enabled is comes up as "Local Access Only" and cannot access the internet.
If I disable both NICs and re-enable the internet NIC first, then all is
good. This is annoying because I leave the computer on with the local NIC on
so the other computer can access the files, but if I want to come and use the
internet, then I have to disable the local NIC, enable the internet NIC, then
when I'm done with the internet I have to disable the internet NIC and
re-enable the local NIC. Other computer is XP and this setup works great on
it.

Sorry for the long post, but I try to be thorough. Any help would be deeply
appreciated.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top