Mouse Settings in Win2k3 Remote Desktop


J

Jon Martin

When I was using the Remote Desktop client to remotely connect to a
Windows 2000 server via terminal services (remote admin mode) the
session would use the right-handed mouse settings of my local
workstation, not the left-handed mouse settings of the remote server.
In this case this is good.

Now the remote server has been configured with Windows 2003. Using the
Remote Desktop client to remotely connect to the server (which is set
up with Win2k3 server's XP-like remote desktop feature, not terminal
services) it is using the left-handed mouse settings of the remote
server instead of the right-handed mouse settings of the local
workstation. This is bad.

Any ideas on how to get the local mouse settings to work on the remote
session??

Many thanks . . .

Jon
 
Ad

Advertisements

B

Bill Sanderson

I have this issue myself with an XP host, and it drives me nuts--however, I
don't know any way to change the behavior.

I just spent some time digging through the policy setting using GPEDIT.MSC,
and I don't see anything related to this behavior of the client.
 
J

Jon Martin

Since my original post I've reconfigured the Win2k3 server to remove
the remote desktop feature and implement the full-blown terminal
services service instead. This did not improve the situation.
 
M

Matthew Harris [MVP]

If you go into the control panel and change the properties
of the mouse buttons and behavior, does this fix the
problem?

-M
 
J

Jon Martin

Matthew,

Yes, but it changes not only the settings for my remote session, but
also for the console session. In Win2k these two were independent.

Jon
 
Ad

Advertisements

J

Jon Martin

What I gather from various sources on this is that with the remote
desktop client running on a Win2k3 or XP client, the mouse takes on
the characteristics of the user profile on the host server. This is no
problem if you have consistent mouse settings on your clients, and
also on your user profiles on the host servers.

The problems I have experienced have two interrelated causes:

1. One client workstation (the desktop at work) had a left-hand mouse
setup. Two others (at home) are right-hand drives.

2. One server (again, my desktop at work) had left hand-drive. All
other servers (the various Win2k servers I manage) I connect to with
the Administrator account and those profiles are all right-handed.

So, basically I am always hosed. Until I find another answer, the
short term answer is to move the trackball on my workstation at work
to the right side so everything I touch is right handed.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top