Memo fields not displaying in query



Greetings -
I am working with Access 2003. I've created a fairly simple table (mostly
text and date fields) that has two memo fields. When I run a query to select
one of the records in the table, the memo fields come up blank. However, if
I run the query to show all of the records, the memo fields show the text.
Any ideas/suggestions as to why the memo fields don't show when I'm
selecting to show only one record?
Thanks in advance!

Dale Fye

Can you post the SQL?

Are you using Distinct or DistinctRow, or any aggregation in the query?


Hi Dale -
No, I'm not using any Distinct or DistinctRow, or any aggregation in the
query. Also, this is a REALLY simple database so I'm not using SQL. Just
simple criteria (a number) to select the record that I want (out of about 80
records). Make sense?

Dale Fye


You stated, "when I run a query to select one of the records, ..."

Well, a query involves SQL, whether you realize it or not.

Open your query in design view, then select the View->SQL from the main
menu. Copy the SQL and post it into your response on this newsgroup.

Are you trying to edit the text in the query? How many rows worth of data
are you displaying? It may be that you have a carraige return at the
beginning of your memo field, so the data is there, you just cannot see it.
This is why we generally recommend that you use forms to view and edit your
data, not queries or tables.


Hi Dale - Thanks for being so helpful and patient with me. Here's the SQL
SELECT RSV_internalQI_data.*
FROM RSV_internalQI_data
WHERE (((RSV_internalQI_data.[CHR Approval number])="H8570-32131"));

I'm not trying to change any data in the query. Rather, I'm trying to make
a query that shows only one of the 100 records that I have in the table so
that I can create a report based on that query that will have only that one
record. If I don't have the "Where" field in the query, the report returns
all 100 records, which is definitely not what we want.
I've created a form to make data entry more user-friendly and that is where
we are adding/changing data. The table has 67 fields. I'm displaying 66 of
them in the query and all of them on the form.
I've checked the memo fields that aren't displaying and there are no
carriage fields at the beginning. I've also removed any formatting to see if
that was the problem but that didn't solve it.

Again, I definitely appreciate your help and suggestions. Any more ideas?


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question