Making Word 2007 default program for opening .doc files


G

Guest

I can't see to set up Word 2007 as my systems default program for opening a
..doc file. I assume its tied to the new file format. But its really
annoying when I open a .doc file off the internet or through an attachment,
and I am being asked to pick a program for Windows to open this file...Pick a
program? Come on...I try to pick winword 2007 but will not allow it. It
doesn't appear in the choices box and when browsing to it, I can select it
but it never works. What is up with that? This is an issue concerning
saving a file in the .doc format. Its about opening a .doc file. I can save
the file to my computer and then open Word 07, click open and select the file
from there, and it works. But if I close it down, and just try to double
click the file at its location, it puts the question to me again about what
program. Please help.
 
Ad

Advertisements

G

Graham Mayor

You need to repair Office 2007 - preferably from the original installation
disc - to ensure that the registry settings are correctly configured.

--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP

My web site www.gmayor.com

<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
 
G

Guest

Does that mean run a Diagnostic, because I did that already and it says there
are no problems found. I'm not getting any sort of message telling me that
something is wrong. So what specifically should I do?
 
H

Herb Tyson [MVP]

If repairing doesn't work, then try right-clicking a .doc file in Windows
Explorer, choose Open With - Choose Default Program.
 
G

Guest

You see that's the problem. When I get to the Default Program menu, Word
2007 is not a choice. Well, just browse right. When I browse to Winword, I
select it, but it doesn't show up in the program box. I can select it, but
doesn't appear as new option. Any suggestions?
 
Ad

Advertisements

H

Herb Tyson [MVP]

In Control Panel's Search box, type "set asso". Under Folder Options,
"Change the file type associated with a file extension" should appear as a
link. Click it.

In the list, click on .doc, then browse, etc.

Does this do it?

If not... I would try to fake Windows out by deliberately setting the
association to something else... verifying that the new association "works"
(i.e., set it to WordPad), then setting it back to Word.

If none of this works... try starting Word using the /r switch.

If that doesn't work... see if Word's associations work correctly using a
new/different Windows user logon.

FWIW... I've found file association settings to be extremely frustrating and
flaky in Vista. There's some aspect which, once corrupted, is very
repair-resistant.

--
Herb Tyson MS MVP
Author of the Word 2007 Bible
Blog: http://word2007bible.herbtyson.com
Web: http://www.herbtyson.com
 
G

Guest

Nothing has worked so far, but I only made it to the point of trying to start
Word using the /r switch. I don't know what that is. Are you suggesting
also to log in under a different user to see what happens as well. We only
have one user for this computer but I'll add another to see what happens if
you think that might work.

Thanks
 
G

Guest

I actually went ahead and created a new user account on Vista, and sure
enough, I went to get a .doc file off the internet and automatically asked me
if I wanted to save or open in Word 2007. Its like under the new account it
automatically associated the file types. I expected that in the original
account as well, and was so puzzled to find that it did not. Is there
anything I can do under the other account to get this to happen?
 
H

Herb Tyson [MVP]

I ran into the identical problem... and--after trying myriad things (such as
copying whole groups of files from the "working" Windows user profile to the
non-working one)--I eventually gave up and migrated to the new user profile.
I determined that the 10+ hours I'd spent trying to fix it was more time
than it would've taken me to customize the new profile.

Of course, this then left me with the unsettling possibility that it could
happen again. Hence, I set frequent restore points, and keep my fingers
crossed.

--
Herb Tyson MS MVP
Author of the Word 2007 Bible
Blog: http://word2007bible.herbtyson.com
Web: http://www.herbtyson.com
 
Ad

Advertisements

G

Guest

Herb

Wow...that seems pretty strange, and disappointing too. Thank you very much
for all your tips and suggestions. Its at least nice to know when someone
else has worked through the same difficulty. Have great day.

Thanks
JC
 
Ad

Advertisements

L

Luvvie

I am having this SAME EXACT problem, and I really do not want to have to
create a new user profile to fix it. Are there any other ways I could resolve
this??
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top