Macros copied to new PC won't enable


P

Piri

I have moved a workbook "Reports.xls" created in Excel-97 containing
formatting macros from my PC to another on the network.

That PC has Office 2000 installed..

The macros will not run on the new location, citing "The macros in this
project have been disabled" etc

The Help file suggests this is due to the Security level of the 2000
version. It mentions going to "Tools, Macro, Security...." in Excel to
change the setting.
But this Excel [2000] does not have the "security.." extension to the
Tool, Macro.." menus?

Any advice appreciated

Piri
 
Ad

Advertisements

A

Anne Troy

It does on my machine. ?
Go to Tools-->Customize, Options tab.
Uncheck the top two checkboxes, and try Tools-->Macro-->Security again.
Then, after you've set to Medium, re-open your workbook.
************
Hope it helps!
Anne Troy
www.OfficeArticles.com
 
P

Piri

Hello Anne,
Thanks for the reply.

Nope .... I have done what you suggest and nothing has changed.
The version of Excel is 2000 (9.0.6926 SP-3)
When I select Tools-->Macro--> all I get is
Macros...
oRecord New Macro...
---------------------
Visual Basic Editor

There is nothing about "security" - the menu looks just like my Excel
8.0 set-up.

Very frustrating.

I did not do the 2000 install and I wonder whether this issue may relate
to the whole Office install, IE security etc.

Cheers,
Piri





Anne said:
It does on my machine. ?
Go to Tools-->Customize, Options tab.
Uncheck the top two checkboxes, and try Tools-->Macro-->Security again.
Then, after you've set to Medium, re-open your workbook.
************
Hope it helps!
Anne Troy
www.OfficeArticles.com

I have moved a workbook "Reports.xls" created in Excel-97 containing
formatting macros from my PC to another on the network.

That PC has Office 2000 installed..

The macros will not run on the new location, citing "The macros in this
project have been disabled" etc

The Help file suggests this is due to the Security level of the 2000
version. It mentions going to "Tools, Macro, Security...." in Excel to
change the setting.
But this Excel [2000] does not have the "security.." extension to the
Tool, Macro.." menus?

Any advice appreciated

Piri
 
A

Anne Troy

Are you at work? If so, perhaps they've disabled it so you cannot run
macros. I cannot imagine why else it would be missing. You could try
Start-->Run:
excel.exe /regserver
and see if that brings it back.
************
Hope it helps!
Anne Troy
www.OfficeArticles.com

Piri said:
Hello Anne,
Thanks for the reply.

Nope .... I have done what you suggest and nothing has changed.
The version of Excel is 2000 (9.0.6926 SP-3)
When I select Tools-->Macro--> all I get is
Macros...
oRecord New Macro...
---------------------
Visual Basic Editor

There is nothing about "security" - the menu looks just like my Excel 8.0
set-up.

Very frustrating.

I did not do the 2000 install and I wonder whether this issue may relate
to the whole Office install, IE security etc.

Cheers,
Piri





Anne said:
It does on my machine. ?
Go to Tools-->Customize, Options tab.
Uncheck the top two checkboxes, and try Tools-->Macro-->Security again.
Then, after you've set to Medium, re-open your workbook.
************
Hope it helps!
Anne Troy
www.OfficeArticles.com

I have moved a workbook "Reports.xls" created in Excel-97 containing
formatting macros from my PC to another on the network.

That PC has Office 2000 installed..

The macros will not run on the new location, citing "The macros in this
project have been disabled" etc

The Help file suggests this is due to the Security level of the 2000
version. It mentions going to "Tools, Macro, Security...." in Excel to
change the setting.
But this Excel [2000] does not have the "security.." extension to the
Tool, Macro.." menus?

Any advice appreciated

Piri
 
P

Piri

I'm feeling little silly about this.
Googled a bit and came up with Reset of the Toolbars/ Menus.
That fixed the problem.

However, it does not explain why I needed to do that given it was a
brand new install of Excel 2000 on a new PC (Server).

Thanks for your help Anne.

Piri


Anne said:
Are you at work? If so, perhaps they've disabled it so you cannot run
macros. I cannot imagine why else it would be missing. You could try
Start-->Run:
excel.exe /regserver
and see if that brings it back.
************
Hope it helps!
Anne Troy
www.OfficeArticles.com

Hello Anne,
Thanks for the reply.

Nope .... I have done what you suggest and nothing has changed.
The version of Excel is 2000 (9.0.6926 SP-3)
When I select Tools-->Macro--> all I get is
Macros...

oRecord New Macro...
---------------------
Visual Basic Editor

There is nothing about "security" - the menu looks just like my Excel 8.0
set-up.

Very frustrating.

I did not do the 2000 install and I wonder whether this issue may relate
to the whole Office install, IE security etc.

Cheers,
Piri





Anne said:
It does on my machine. ?
Go to Tools-->Customize, Options tab.
Uncheck the top two checkboxes, and try Tools-->Macro-->Security again.
Then, after you've set to Medium, re-open your workbook.
************
Hope it helps!
Anne Troy
www.OfficeArticles.com



I have moved a workbook "Reports.xls" created in Excel-97 containing
formatting macros from my PC to another on the network.

That PC has Office 2000 installed..

The macros will not run on the new location, citing "The macros in this
project have been disabled" etc

The Help file suggests this is due to the Security level of the 2000
version. It mentions going to "Tools, Macro, Security...." in Excel to
change the setting.
But this Excel [2000] does not have the "security.." extension to the
Tool, Macro.." menus?

Any advice appreciated

Piri
 
A

Anne Troy

No clue, Piri. I seldom waste my time trying to figure out "why". :)
************
Hope it helps!
Anne Troy
www.OfficeArticles.com
Check out: www.ExcelUserConference.com

Piri said:
I'm feeling little silly about this.
Googled a bit and came up with Reset of the Toolbars/ Menus.
That fixed the problem.

However, it does not explain why I needed to do that given it was a brand
new install of Excel 2000 on a new PC (Server).

Thanks for your help Anne.

Piri


Anne said:
Are you at work? If so, perhaps they've disabled it so you cannot run
macros. I cannot imagine why else it would be missing. You could try
Start-->Run:
excel.exe /regserver
and see if that brings it back.
************
Hope it helps!
Anne Troy
www.OfficeArticles.com

Hello Anne,
Thanks for the reply.

Nope .... I have done what you suggest and nothing has changed.
The version of Excel is 2000 (9.0.6926 SP-3)
When I select Tools-->Macro--> all I get is

Macros...

oRecord New Macro...
---------------------
Visual Basic Editor

There is nothing about "security" - the menu looks just like my Excel
8.0 set-up.

Very frustrating.

I did not do the 2000 install and I wonder whether this issue may relate
to the whole Office install, IE security etc.

Cheers,
Piri





Anne Troy wrote:

It does on my machine. ?
Go to Tools-->Customize, Options tab.
Uncheck the top two checkboxes, and try Tools-->Macro-->Security again.
Then, after you've set to Medium, re-open your workbook.
************
Hope it helps!
Anne Troy
www.OfficeArticles.com



I have moved a workbook "Reports.xls" created in Excel-97 containing
formatting macros from my PC to another on the network.

That PC has Office 2000 installed..

The macros will not run on the new location, citing "The macros in this
project have been disabled" etc

The Help file suggests this is due to the Security level of the 2000
version. It mentions going to "Tools, Macro, Security...." in Excel to
change the setting.
But this Excel [2000] does not have the "security.." extension to the
Tool, Macro.." menus?

Any advice appreciated

Piri
 
Ad

Advertisements

G

Guest

Ann,

I created a soreadsheet with macros in it. In my work environment most
users are not Admins on their boxes. I keep running into a requirement to
sign my macros, but that seems to involve buying a certificate for $$$ and
this is just "too much" for the simple need I have!

How would I get my macros to work on those systems on Excel 2003? Pointers
to articles woudl be appreciated as well as direct answers.

Anne Troy said:
Are you at work? If so, perhaps they've disabled it so you cannot run
macros. I cannot imagine why else it would be missing. You could try
Start-->Run:
excel.exe /regserver
and see if that brings it back.
************
Hope it helps!
Anne Troy
www.OfficeArticles.com

Piri said:
Hello Anne,
Thanks for the reply.

Nope .... I have done what you suggest and nothing has changed.
The version of Excel is 2000 (9.0.6926 SP-3)
When I select Tools-->Macro--> all I get is
Macros...
oRecord New Macro...
---------------------
Visual Basic Editor

There is nothing about "security" - the menu looks just like my Excel 8.0
set-up.

Very frustrating.

I did not do the 2000 install and I wonder whether this issue may relate
to the whole Office install, IE security etc.

Cheers,
Piri





Anne said:
It does on my machine. ?
Go to Tools-->Customize, Options tab.
Uncheck the top two checkboxes, and try Tools-->Macro-->Security again.
Then, after you've set to Medium, re-open your workbook.
************
Hope it helps!
Anne Troy
www.OfficeArticles.com


I have moved a workbook "Reports.xls" created in Excel-97 containing
formatting macros from my PC to another on the network.

That PC has Office 2000 installed..

The macros will not run on the new location, citing "The macros in this
project have been disabled" etc

The Help file suggests this is due to the Security level of the 2000
version. It mentions going to "Tools, Macro, Security...." in Excel to
change the setting.
But this Excel [2000] does not have the "security.." extension to the
Tool, Macro.." menus?

Any advice appreciated

Piri
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top