Macro security


G

Guest

Hi,

Currently I have Excel 2003 on XP operating system.

In the past, before migrating to this advanced version, I had macro security
set to MEDIUM whereby everytime I open a spreadsheet that contains macros the
Excel software prompts me if I would like to enable or disable the macros.

With the migration to Excel 2003, I cannot seem to re-establish this
setting. I tried via TOOLS - OPTIONS - SECURITY and I also tried via TOOLS -
MACRO - MACRO SECURITY.

But via both means, after setting the security to MEDIUM, i close .xls and
re-open it using a workbook containing macros and there is absolutely no
prompt. On re-verifying the option settings I discover that it has switched
back to LOW.

How can I permanently re-establish this setting?
 
Ad

Advertisements

D

Dave Peterson

This is a setting that's kept in the Windows Registry. If your system
administrators don't want you to save changes there, you'll want to complain to
them. Maybe they can make you the single exception???
 
G

Gord Dibben

Excel's macro security level settings are saved in the Registry.

HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Security

On rightside window Level should be 2 for medium.

Perhaps you do not have sufficient rights to alter the Registry.

Someone with administrator rights may have to make the changes.


Gord Dibben MS Excel MVP
 
G

Guest

I consulted my registry setting as explained by you i.e.

HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Security

For LEVEL I see the data as 2, type is REG_DWORD.


I suppose this is what you are referring to? If that is the case, then how
come I do not get a prompt asking me to ENABLE or DISABLE macros or NOT TO
OPEN the file?

Thanks in anticipation.
 
G

Gord Dibben

The entire DWORD value looks like 0x00000002(2)

If that is the case then I don't know why your Excel keeps defaulting to "Low"

In Excel Tools>Options>Security set the level to "medium" then close Excel.

Re-open.

Has the setting stuck?


Gord

I consulted my registry setting as explained by you i.e.

HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Security

For LEVEL I see the data as 2, type is REG_DWORD.


I suppose this is what you are referring to? If that is the case, then how
come I do not get a prompt asking me to ENABLE or DISABLE macros or NOT TO
OPEN the file?

Thanks in anticipation.

Gord Dibben MS Excel MVP
 
G

Guest

Yes, the setting is exactly as you mention.

Thanks for the help, but it seems that I am once again stuck with a
completely abnormal situation. FYI: I did change the security setting as you
requested, closed Excel, restarted excel and the setting is back to LOW.
 
Ad

Advertisements

G

Gord Dibben

Shrug......slap forehead.......and leave.

I don't know what's happening.

Will keep playing and might come up with something.

I googled the Excel groups and all I could find was basically same as Dave's and
my own thoughts.


Gord

Yes, the setting is exactly as you mention.

Thanks for the help, but it seems that I am once again stuck with a
completely abnormal situation. FYI: I did change the security setting as you
requested, closed Excel, restarted excel and the setting is back to LOW.

Gord Dibben MS Excel MVP
 
Ad

Advertisements

D

Dave Peterson

I've seen a couple of posts that describe a problem that the user couldn't
change the setting in xl2003 via the user interface because it was greyed out.

But this doesn't sound like the same situation as the OP's.

Here's one by Jan Karel Pieterse

==================
if you are using Excel 2003 the box in
macro security options is greyed out.

the registry setting was moved from user to machine
and you can no longer change it from the UI.

Run the program regedit.exe
goto:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\11.0\Excel\Security
Add or Change a DWORD named AccessVBOM to Value 1

Changing the registry value changes the setting, but it stays grey.

Removing the registry entry effectively gives the control back to
Excel.

So: If you add that registry entry, the only way to change the "trust
access to VB projects" setting is by either removing the entry (and
then change it in Excel), or by changing it in the registry.

Sounds like an administrator sort of reg entry to enforce a security
setting on users.

Regards,

Jan Karel Pieterse
http://www.jkp-ads.com

==============
Maybe DKS can look for entry in the registry.

Remember to backup the registry before you turn your pc into a boat anchor!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top