Macro security


R

R Ormerod

My macro security level is currently set to Medium. This should mean that
every time I open a file containing macros I should see the option to Disable
/ Enable macros.

Recently I have noticed that this message is only appearing intermittently
i.e. files are sometimes opening without giving me this option. Macros

I cannot see any obvious pattern to this - it seems to happen with various
files.

Any ideas what might be causing this?
 
Ad

Advertisements

J

Jim Rech

Depends on your Excel version but some locations are deemed 'trusted'.

--
Jim
| My macro security level is currently set to Medium. This should mean that
| every time I open a file containing macros I should see the option to
Disable
| / Enable macros.
|
| Recently I have noticed that this message is only appearing intermittently
| i.e. files are sometimes opening without giving me this option. Macros
|
| I cannot see any obvious pattern to this - it seems to happen with various
| files.
|
| Any ideas what might be causing this?
| --
| R Ormerod
 
R

R Ormerod

I have Excel 2003 SP2.

Could another factor be file size? One file where the macros are
consistently disabled is 51MB, whereas smaller files on the whole seem to be
working OK.
 
J

Jim Rech

Size is not the issue I do not believe. Virus writers would really take
advantage of that if it were so. Take a workbook that opens with no warning
and copy it to some other location that is not likely to be trusted like a
new folder under C:\ and see what happens.

--
Jim
|I have Excel 2003 SP2.
|
| Could another factor be file size? One file where the macros are
| consistently disabled is 51MB, whereas smaller files on the whole seem to
be
| working OK.
|
| --
| R Ormerod
|
|
| "Jim Rech" wrote:
|
| > Depends on your Excel version but some locations are deemed 'trusted'.
| >
| > --
| > Jim
| > | > | My macro security level is currently set to Medium. This should mean
that
| > | every time I open a file containing macros I should see the option to
| > Disable
| > | / Enable macros.
| > |
| > | Recently I have noticed that this message is only appearing
intermittently
| > | i.e. files are sometimes opening without giving me this option. Macros
| > |
| > | I cannot see any obvious pattern to this - it seems to happen with
various
| > | files.
| > |
| > | Any ideas what might be causing this?
| > | --
| > | R Ormerod
| >
| >
| >
 
J

Jim Rech

Take a workbook that opens with no warning

That has macros, of course. <g>

--
Jim
| Size is not the issue I do not believe. Virus writers would really take
| advantage of that if it were so. Take a workbook that opens with no
warning
| and copy it to some other location that is not likely to be trusted like a
| new folder under C:\ and see what happens.
|
| --
| Jim
| ||I have Excel 2003 SP2.
||
|| Could another factor be file size? One file where the macros are
|| consistently disabled is 51MB, whereas smaller files on the whole seem to
| be
|| working OK.
||
|| --
|| R Ormerod
||
||
|| "Jim Rech" wrote:
||
|| > Depends on your Excel version but some locations are deemed 'trusted'.
|| >
|| > --
|| > Jim
|| > || > | My macro security level is currently set to Medium. This should mean
| that
|| > | every time I open a file containing macros I should see the option to
|| > Disable
|| > | / Enable macros.
|| > |
|| > | Recently I have noticed that this message is only appearing
| intermittently
|| > | i.e. files are sometimes opening without giving me this option.
Macros
|| > |
|| > | I cannot see any obvious pattern to this - it seems to happen with
| various
|| > | files.
|| > |
|| > | Any ideas what might be causing this?
|| > | --
|| > | R Ormerod
|| >
|| >
|| >
|
|
 
R

R Ormerod

I copied the file to my C:\drive and the Security Warning dialog now appears
every time I open it.

The problem I is that the master copy of the file is located in a directory
on a company server that I cannot change. Up to a few weeks ago this had
never happened before, so where can I change the file or directory properties
to make it an 'untrusted' source again?

Also, I tried changing my macro security settings to Low so that the macros
would be automatically enabled but I think I am prevented from doing this as
it always reverts to medium.
 
Ad

Advertisements

J

Jim Rech

Re macro security you are the victim I think of a corporate policy. That
policy is saved here in the registry:

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\11.0\Excel\Security\Level

You'd want to change Level from 2 to 1 (or delete Level) using the
Regedit.exe program but you may not have the rights.

I think the network folder being trusted is a policy too. Even if you could
change it on your machine you couldn't on other users' machines. I don't
know where that setting is in any case.

--
Jim
|I copied the file to my C:\drive and the Security Warning dialog now
appears
| every time I open it.
|
| The problem I is that the master copy of the file is located in a
directory
| on a company server that I cannot change. Up to a few weeks ago this had
| never happened before, so where can I change the file or directory
properties
| to make it an 'untrusted' source again?
|
| Also, I tried changing my macro security settings to Low so that the
macros
| would be automatically enabled but I think I am prevented from doing this
as
| it always reverts to medium.
|
| --
| R Ormerod
|
|
| "Jim Rech" wrote:
|
| > Size is not the issue I do not believe. Virus writers would really take
| > advantage of that if it were so. Take a workbook that opens with no
warning
| > and copy it to some other location that is not likely to be trusted like
a
| > new folder under C:\ and see what happens.
| >
| > --
| > Jim
| > | > |I have Excel 2003 SP2.
| > |
| > | Could another factor be file size? One file where the macros are
| > | consistently disabled is 51MB, whereas smaller files on the whole seem
to
| > be
| > | working OK.
| > |
| > | --
| > | R Ormerod
| > |
| > |
| > | "Jim Rech" wrote:
| > |
| > | > Depends on your Excel version but some locations are deemed
'trusted'.
| > | >
| > | > --
| > | > Jim
| > | > | > | > | My macro security level is currently set to Medium. This should
mean
| > that
| > | > | every time I open a file containing macros I should see the option
to
| > | > Disable
| > | > | / Enable macros.
| > | > |
| > | > | Recently I have noticed that this message is only appearing
| > intermittently
| > | > | i.e. files are sometimes opening without giving me this option.
Macros
| > | > |
| > | > | I cannot see any obvious pattern to this - it seems to happen with
| > various
| > | > | files.
| > | > |
| > | > | Any ideas what might be causing this?
| > | > | --
| > | > | R Ormerod
| > | >
| > | >
| > | >
| >
| >
| >
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top