Locate Link Browser



I am running Windows XP Pro SP2 with Office 2003 SP2 (having now uninstalled
Office 2007 beta). I commonly use Firefox as browser. I stupidly updated
IE7 to 7.0.5730.11 and now, when I click a link in an email I get this
message. I searched in Google and found the fix that I copy here:To resolve this problem, follow these steps to clear the Use DDE check box:
1. Double-click My Computer.
2. On the Tools menu, click Folder Options.
3. On the File Types tab, click URL:MailTo Protocol in the Registered
File Types list, and then click Edit.
4. In the Actions box, click Open, and then click Edit.
5. Click to remove the Use DDE check box, and then click OK.
6. Click Close two times. <<

I did as advised here but even if I "click OK and Close two times" (actually
it is not "OK and Close two times" but OK two times and Close), the Use DDE
turns back to checked because instead of the last Close I should click Apply
but I can not because the Apply box is greyed.

In the procedure, I noticed that the application used to perform the action
was "C:\PROGRA~1\MICROS~3\OFFICE11\OUTLOOK.EXE" therefore, the next time I
got the Locate Link Browser message I went to Program Files etc... and
clicked on Outlook.exe. Now I don't have the message anymore but when I
click on a link in an email, Outlook opens it, instead of Firefox (of
course, because I provided it to the program).

What is strange is that some links actually return a valid page and some
others return a "page not found". As the page not found message happened a
bit too often, I tried to open the same links using Firefox (by reading my
email directly on Gmail) and those links, dead in Outlook, were _not_ dead
on Firefox. Strange. But anyway I would like to read on Firefox rather
than on Outlook, as I used to do before updating IE7 to the last version.

I went back to the procedure and replaced the Outlook.exe link by the
Firefox.exe one but it still reads the links in Outlook, as I provided the
link when I had the locate link browser the first time and now I don't have
this message anymore so I can't change the link.

Could someone help and tell me how to fix this problem, I would be extremely


Thank you very much for trying to help.

Unfortunately, when I follow the instructions:
a.. Select Extension: (NONE), File Type: URL:HyperText Transfer Protocol
a.. Click Advanced toward the bottom of the window
a.. In the Edit File Type window, select open and click Edit
a.. Repeat for File Type: HyperText Transfer Protocol with Privacy and FTP

the Edit button is greyed i.e. inaccessible for all the occurrences
(URL:HyperText Transfer Protocol, HyperText Transfer Protocol with Privacy
and FTP).

I also tried the alternative method:but without success.

I found out why I had all those Page not found. I think that it is because
the following text is added to the link:


Diane Poremsky said:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question