Invalid system disk booting to Win2K


S

Smylnjak

I had carved up a 40GB HDrive into 3 Op/Sys and 1 extended
partition using Partition Magic. This has worked
successfully in the past with P1=W98 P2=Win2K and P3=
Linux. (4th partn. is extended and held data used when
booting to other partitions. P2 and P3 hidden when booting
W98.

I deleted the Win98 O/S and expanded P1 and P2 to be one
partition leaving the rest untouched, and now I get
the "invalid system disk" error when booting up.

I have created a W2K boot disk with boot.ini,ntdetect.com,
and ntldr and when using that in the A; (floppy drive) the
PC boots to Win2K like it should. Note C:\ does have the
same boot.ini, ntldr etc as on the floppy.;

I have tried repair boot sector with emergency w2k backup
disk but still no dice.

I suspect I trashed a partition table somewhere, maybe the
master boot record. I dunno.

In W98 there was a repair master boot function in
FDISK /MBR. Does WIN2K have something similar or.....

Since the invalid system disk error I've tried using the
win98 and WinMe FDISK but no go.

Ideas?

THANKS!

Jäck
 
Ad

Advertisements

P

Pegasus \(MVP\)

See below.

in message I had carved up a 40GB HDrive into 3 Op/Sys and 1 extended
partition using Partition Magic. This has worked
successfully in the past with P1=W98 P2=Win2K and P3=
Linux. (4th partn. is extended and held data used when
booting to other partitions. P2 and P3 hidden when booting
W98.
*** What drive did each OS run from? Was it always drive C:?

I deleted the Win98 O/S and expanded P1 and P2 to be one
partition leaving the rest untouched, and now I get
the "invalid system disk" error when booting up.
*** Did you make the resulting partition active?
*** Is it a FAT32 or an NTFS partition?

I have created a W2K boot disk with boot.ini,ntdetect.com,
and ntldr and when using that in the A; (floppy drive) the
PC boots to Win2K like it should. Note C:\ does have the
same boot.ini, ntldr etc as on the floppy.;

I have tried repair boot sector with emergency w2k backup
disk but still no dice.

I suspect I trashed a partition table somewhere, maybe the
master boot record. I dunno.
*** If your partition table was thrashed then you would
*** not be able to boot at all!

In W98 there was a repair master boot function in
FDISK /MBR. Does WIN2K have something similar or.....

Since the invalid system disk error I've tried using the
win98 and WinMe FDISK but no go.

Ideas?

THANKS!

Jäck
========================
Please supply full details about what types of partitions
you have, and what is on them. You should also post the
contents of boot.ini.

It is likely that your new partition has an invalid MBR.
This is easy to fix.
 
J

Jack

Mahalo (Thanks) to Pegasus for answering.

Data as requested follows;.........

Current BOOT.INI=
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft
Windows 2000 Professional" /fastdetect

Partition Magic shows P1 is primary and active.

When booting previous config, resulting active partition
always showed as C: Don't have prior BOOT.INI

This is where I could sure use some help as I have only
repaired MBR's on W9x PC's with the FDISK /MBR command.

Easy ? ? ? ?


More data on the problem as requested:

Current config for 40 GB IDE drive

2 primary 1 extended partn. W2K O/S in P1, Data in P2,
more data in Xtnd partn. ALL FAT32

Prior config:
3 primary, 1 Xtnd pARTN, p1 = WIN2k P2 DATA P3 Win98,
xtnd = data all FAT32

-----Original Message-----
See below.

"[email protected]@aol.com"
 
Ad

Advertisements

P

Pegasus \(MVP\)

See below.


Mahalo (Thanks) to Pegasus for answering.

Data as requested follows;.........

Current BOOT.INI=
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft
Windows 2000 Professional" /fastdetect
*** This file looks fine.

Partition Magic shows P1 is primary and active.
*** Good.

When booting previous config, resulting active partition
always showed as C: Don't have prior BOOT.INI

This is where I could sure use some help as I have only
repaired MBR's on W9x PC's with the FDISK /MBR command.
Easy ? ? ? ?
*** Since your boot partition is FAT32, you can do this:
*** Boot the machine with a Win98 boot disk from www.bootdisk.com.
*** Get bootpart.exe from
*** http://ourworld.compuserve.com/homepages/gvollant/bootpart.htm
*** Run this command:
*** bootpart winnt boot:c:
*** This will restore your Win2000 boot sector. You can now boot
*** off the hard disk.

More data on the problem as requested:

Current config for 40 GB IDE drive

2 primary 1 extended partn. W2K O/S in P1, Data in P2,
more data in Xtnd partn. ALL FAT32

Prior config:
3 primary, 1 Xtnd pARTN, p1 = WIN2k P2 DATA P3 Win98,
xtnd = data all FAT32

-----Original Message-----
See below.

"[email protected]@aol.com"
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top