Internal Error 2755. 110 on install from .msi execution

Discussion in 'Anti-Spyware Installation' started by Guest, Oct 8, 2005.

  1. Guest

    Guest Guest

    On XPSP2 with latest Genuine Advantage Tool (which updated MS installer), I
    just downloaded the beta MicrosoftAntiSpywareInstall.exe, ran it as local
    admin, and this error occurred. From KB articles on this error, it would
    appear that %windir%\installer permissions might be wrong, but they aren't,
    admin & system have full control. However, from Google search results, it
    appears the NTFS EFS (encrypting file system) causes problems if the
    installer package is encrypted. But I have only "My Documents", and Local
    Settings\Temp and Local Settings\Application Data encrypted for obvious
    reasons. EFS is probably the culprit here, but if anyone knows different,
    please let me know.

    Full error text from Application Log Event# 10005, source MsiInstaller:

    Product: Microsoft AntiSpyware -- Internal Error 2755. 110,
    C:\WINDOWS\Downloaded
    Installations\{78CB0701-6520-4FAE-99CE-20DE50BEF25C}\Microsoft AntiSpyware.msi
     
    Guest, Oct 8, 2005
    #1
    1. Advertisements

  2. Interesting. I googled a bunch of stuff, and it all seemed to revolve
    around permissions--I didn't spot any references to EFS. I'd have thought
    that EFS was supposed to be transparent.

    I can imagine that the encryption of TEMP may be the issue here, if EFS is
    really at fault.

    I've EFS encrypted TEMP and am running a "repair" via control panel, add or
    remove programs--but my CPU is pegged (piii-750)--so I'm not sure what is
    happening--haven't seen the error message anyway. I think I will kill this
    and try an uninstall/reinstall.
     
    Bill Sanderson, Oct 8, 2005
    #2
    1. Advertisements

  3. OK - I can confirm.

    I encrypted TEMP, did an uninstall, and a reinstall, and it failed with the
    same 2755 error message.

    I investigated the installer file noted in the error message, and found that
    it was marked in green as being encrypted--perhaps as a result of an
    unjudicious move from TEMP.

    In order to reinstall successfully, I unencrypted TEMP, and deleted that
    installer file noted in the error message. I could then reinstall
    successfully.

    I'll pass this on.
     
    Bill Sanderson, Oct 8, 2005
    #3
  4. Guest

    Guest Guest

    I configured Local Settings\Temp to be unencrypted, and re-ran the .exe
    install. But this did not solve the problem.

    When I looked at the file path mentioned in the error, yes in fact, the .msi
    file was encrypted, but I don't know why. Since I had not configured higher
    parts of the path to be encrypted, nor did I have the .exe encrypted. Anyway,
    I changed the properties on the .msi to be decrypted, and re-ran the .exe
    downloaded to install. I had downloaded the .exe to C:\Program
    Files\Downloads (a directory of my own creation), from which I ran the .exe
    through file explorer by double-clicking. It appears to have overwritten the
    same .msi file at the same path (C:\WINDOWS\Downloaded
    Installations\{78CB0701-6520-4FAE-99CE-20DE50BEF25C}\Microsoft
    AntiSpyware.msi).

    Now that this particular .msi was not encrypted, the installation has
    completed.

    Thanks for the investigate Bill.
     
    Guest, Oct 8, 2005
    #4
  5. I suspect that the installer routines will be very different for beta2, but
    I'll pass this on in case it either isn't something they've spotted.

    Am I correct in assuming that you've successfully installed other .MSI based
    products on this system--so this isn't a generic issue with the installer?
    You did mention that this was the first time you've done an install with 3.1
    of the installer? I doubt that's the root of this, though.

    --
     
    Bill Sanderson, Oct 9, 2005
    #5
  6. Guest

    HighTech

    Joined:
    Oct 21, 2008
    Likes Received:
    0
    Very good solution

    Very good solution.

    1. just go to the folder where the .msi file is found and right click -> properties -> advanced -> Uncheck the box: Encrypt content to secure data.
    In my case the path of the .msi was C:\Documents and Settings\myUser\Application Data\Sun \Java\jdk1.6.0_10

    2. Run the JDK again and it will work.

    Note: If it does not work just go the Sun folder instead and do the same as explained above and select all the subfolder and files before you click apply/ok

    HighTech
     
    Last edited: Oct 21, 2008
    HighTech, Oct 21, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.