install & version questions


P

Paul

Hi,



I am installing a program called primoPDF and it requires that .net
framework 2.0 be installed first. I already have .net framework 1.1
installed.



Questions:



Should I un-install .nfw 1.1 before installing .nfw 2.0? Or will installing
2.0 automaticly un-install 1.1?



Is it OK to have more that one version of .nfw installed?



I already have a program installed that requires .nfw 1.1, if I un-install
..nfw 1.1 and install .nfw 2.0, will my program that had required .nfw 1.1
work with .nfw 2.0



Should I just skip installing .nfw 2.0 and install the latest .nfw 3.5 ?
Should primoPDF that required .nfw 2.0 work with .nfw 3.5 ?



Thanks..
 
Ad

Advertisements

R

RobinS

Answers below.

-----------------------------------
Paul said:
Hi,



I am installing a program called primoPDF and it requires that .net
framework 2.0 be installed first. I already have .net framework 1.1
installed.



Questions:



Should I un-install .nfw 1.1 before installing .nfw 2.0? Or will
installing 2.0 automaticly un-install 1.1?

No. No. They are completely different versions, 2.0 is not an upgrade to
1.1.
Is it OK to have more that one version of .nfw installed?

Yes. Most people do. I have 1.1, 2.0, and 3.0 all installed.
I already have a program installed that requires .nfw 1.1, if I
un-install .nfw 1.1 and install .nfw 2.0, will my program that had
required .nfw 1.1 work with .nfw 2.0

No. They are completely different copies of the framework.
Should I just skip installing .nfw 2.0 and install the latest .nfw 3.5 ?
Should primoPDF that required .nfw 2.0 work with .nfw 3.5 ?

That's your choice, but I think installing 3.5 will work for 2.0, 3.0, and
3.5 applications. I am pretty sure that 3.5 is 2.0 + 3.0 (which is just 2.0
+ some extra bits) + some more extra bits. 3.5 includes SP-1 to .Net 2.0 and
..Net 3.0, so my guess would be that it installs those versions of the
framework if you don't have them. That's what it looks like, according to
http://www.microsoft.com/downloads/...FD-AE52-4E35-B531-508D977D32A6&displaylang=en


I'm sure I will be corrected if I am wrong.

You're welcome.

RobinS.
GoldMail, Inc.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top