Install error after domain name change


C

ChrisB

I'm using VC .NET 2002 to generate an MSI for my
application.

We store the .msi on a network share so that workstations
may install from a central location.

Everything has been working great until my company
decided to change domain names. This domain name change
really freaks the MSI installer out. Now when anyone
tries to install the same .MSI from the same share, the
installer issues the message:

"The advertised application will not be installed because
it might be unsafe. Contact your administrator to change
the installation user interface option of the package to
basic."

I'm the administrator and I have no idea what this
means. Furthermore, we cannot uninstall the application
because the installer gives this same message--truly
annoying! So we can't get by this issue.

All workstations have administrative access so this is
not the problem.

Can anybody help?

Thanks!
 
Ad

Advertisements

C

Carolyn Napier [MSFT]

That error message is specific to Visual Studio generated packages. Visual
Studio specifically requires that packages created using it be deployed with
only a basic UI interface through software deployment. And the Installer isn't
"getting freaked out", it's actually doing what the package tells it to do.

If you take a look at your MSI using a tool like Orca, you should find the
following in the Property table:

VSDUIANDADVERTISED This advertised application will not be installed because it
might be unsafe. Contact your administrator to change the installation user
interface option of the package to basic.

If you then go to the CustomAction table, you'll find the following row for a
type 19 custom action that makes use of this error message:

ERRCA_UIANDADVERTISED 19 [VSDUIANDADVERTISED]


If you then look in your InstallUISequence table, you'll find the following row:
ERRCA_UIANDADVERTISED ProductState=1 1

This custom action will fire whenever the ProductState value is 1 which means
whenever the product is advertised. So if you attempt to execute the package in
full UI mode, your installation will fail if the product has been advertised.
This is the situation when you assign or publish an application using Group
Policy - Software Deployment.

The Visual Studio created package requires that when deploying the package, you
choose "Basic" as the user interface option instaead of "Maximum". This is
usually requires selecting "Advanced Deployment" and then on the Deployment tab
choosing the UI level.

Hope this helps,
- Carolyn Napier
Microsoft Windows Installer Team

--
This posting is provided "AS IS" with no warranties, and confers no rights.
Please do not send email directly to this alias. This alias is for newsgroup
purposes only.

MSI FAQ:
<http://www.microsoft.com/windows2000/community/centers/management/msi_faq.mspx>
 
Joined
Oct 22, 2008
Messages
3
Reaction score
0
Carolyn Napier [MSFT] said:
The Visual Studio created package requires that when deploying the package, you
choose "Basic" as the user interface option instaead of "Maximum". This is
usually requires selecting "Advanced Deployment" and then on the Deployment tab
choosing the UI level.

I'm having the same problem here on a Windows XP SP2 system. I just ran a System Repair...would this have affected it?

I installed Super Orca and the tags were exactly as you assumed they were in Chris's case.

I'm not sure where this "Basic", "Maximum", and Deployment tab are, or how to access them, but I do know that the program works on some computers and not others.

What settings need changed in order for the msi to launch, and how in the world do I get to them?

Edit: I was able to install by logging into another profile. Both are administrators...what difference did that make?
 
Last edited:
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top