Importing Excel Data Into MS Access Memo Field


Mike S. S.

I have a column of text data in Excel whose cells run into thousands of
characters. When I try to import it, Access truncates the text, even if I
save the Excel file as delimited text and import. I know there is a way to
tell Access a minimum char size even for a memo field but I can't find where
to do this in the process. So what is the problem with Importing, whether an
XLS or a TxT file? I also noticed when linking the Excel file that the
column with the large text values are also truncated, but I thought that
might have more to do wtih linking rather than importing.

Oct 9, 2008
Reaction score
You should try importing to access from excel following this steps:
1. prepare blank database with correct MEMO field in access
2. from access import excel into access via append option
3. produce "return" chr(32) charatcter in word (enable Show paragrphs marks...)
4. copy it
5. open find replace dialog box
6. find "return" character, replace blank
7. remove all via find-replace function
For me it works, memo fields are not truncated! They were not before, it only looked like.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question