I press upper shift & " BUT I get @ - how can I fix it?


G

Gorilla_Bear

When I use the upper shift key and the number 2 to acheive the " sign....I
get the @ sign instead. How can I fix it?

thanks for any help on this...its doing my dome in big style.
 
Ad

Advertisements

R

Roger Govier

Hi

Windows>Control panel>Regional Settings>make sure you have the correct
keyboard setting selected.
 
B

Bob Phillips

I get this as well, I am working happily, and then suddenly the @ becomes a
", and I even lose the #.

My reasoning is that because US keyboards are laid out differently than UK
keyboards, and because US application designers think US is the world, there
is code in these apps which fails in certain situations and it becomes US
specific, so we are saddled with an implicit US keyboard.

I have never found a solution.

--
---
HTH

Bob


(there's no email, no snail mail, but somewhere should be gmail in my addy)
 
G

Gorilla_Bear

Hi Roger:

Thanks for taking the time to help me out - its much appreciated. After
posting my question, I did check control problem and I had UK settings, but
judging by the second reply to my question, maybe that was my problem?

Anyway, my computer fell over and after rebooting and checking itself - all
was fine again.

Very strange and creepy - the whole incident has jserved to remind me to
backup my latest data to my external harddrive.

thanks again.
 
G

Gorilla_Bear

Thanks for your reply Bob, it made a lot of sense - looks like the USA are
like the roman empire of old...they've spread their influence even to our
keyboard selections...D'oh!!

I think if it happens again - its time for a cheeky re-boot - methinks.

All the best.
 
B

Bob Phillips

I have never found a foolproof correction (Other than a reboot). Sometime
restarting Excel does it, sometimes it seems to correct itself (just when
you have gotten used to it), but I have never noticed the trigger.

--
---
HTH

Bob


(there's no email, no snail mail, but somewhere should be gmail in my addy)
 
Ad

Advertisements

M

MartinW

Hi,

It could possibly be a driver file issue.
Have you tried updating your keyboard driver file?

HTH
Martin
 
Ad

Advertisements

S

Stenoaud

Hi you two,

I've just come onto "help" trying to find a solution to the keyboard change
from UK to US and, with some inspiration from all the chat about the problem
here, I've solved it for myself. I'm so thrilled that I want to share the
info with others in the hope it will work for them.

If you press Alt+Shift together it alters the keyboard from UK to US and
alters the £ sign to " to # and @ and the autocorrect doesn't always work.
For a quick fix just press Alt+Shift again. But to take out that "macro" go
to Control Panel - Regional & language options - Languages - details -- key
settings - change key sequence - alter them to none by removing the ticks.

I realise that your dialogue was happening a while ago but maybe it will
help someone at some time. This will put an end to 18 months of frustrated
for me.

Stenoaud.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top