I don't see the "safely remove" icon in systray



I use Windows XP pro, which is fully updated via Automatic Updates - When I plug in either my HDD mp3 player (iRiver iHP-140) or external USB HDD, I don't get the icon in systray that gives me the function to "safely remove" the device.

According to literature that came with both devices, it is very important that I use this function. I have tried connecting each device via USB ports direct on my motherboard, & also via a USB hub but still no systray icon. All my ports are USB 2.0. I've also tried having just the one USB device connected to the PC at any one time, in case any other standard USB devices were causing conflictions. Still no joy though.

Any ideas gratefully received.

Regards, Gavin.


Hi Gavin

There are few things you can try on your system. It seems this problem can occur if you do not use a password to log onto your machine with. Try setting a password and logging on again with your account, any good? You should be able to remove the password afterwards if this has worked.

If this does not work you can try this:


If you still have the problem I would be inclined to reinstall SP1.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question