How do I set a FQDN name for (SMTP) EHLO in Outlook?


G

Guest

By default Outlook uses a %COMPUTERNAME% (that need not obey any DNS rules)
in the EHLO/HELO identification string. To be RFC 2821 compliant this string
must be a FQDN or a valid address literal. Is there any way to set this
value? Checking this value can help in fighting spam so there should be an
easy way for a proper setting.
thanks
 
D

Diane Poremsky [MVP]

the addresses used in EHLO/HELO are supposed to be added by the SMTP server
and outlook only adds if it the server does not.
 
Ad

Advertisements

G

Guest

I think I should give more details:
The Outlook installation is on a notebook using various internet connections
(depending on local availability) to connect to the company mailserver (3rd
party product, that checks the EHLO/HELO name) to receive (IMAP) and send
(SMTP) mail. The problem arise when a message from Outlook is transferred to
the server (via SMTP) to be sent to the final recipient. The message comes
from the "outside world" and has to obey the same rules as any other
incomming message. So when the notebook connects and says "EHLO notebook-no1"
or like, it recieves a 4xx (or maybe 5xx if more strict rule apply) response
(incorrect params) and the connection is rejected.
If there is a way to instruct the client to use a name like "EHLO
mobileuser.company.com" having a valid A record in the company.com zone, the
message would pass to the server and be regularly processed.

any idea (other than switch off the name checking)?

zbynek

Diane Poremsky said:
the addresses used in EHLO/HELO are supposed to be added by the SMTP server
and outlook only adds if it the server does not.

--
Diane Poremsky [MVP - Outlook]
Author, Teach Yourself Outlook 2003 in 24 Hours
Coauthor, OneNote 2003 for Windows (Visual QuickStart Guide)
Need Help with Common Tasks? http://www.outlook-tips.net/beginner/






zbynek said:
By default Outlook uses a %COMPUTERNAME% (that need not obey any DNS
rules)
in the EHLO/HELO identification string. To be RFC 2821 compliant this
string
must be a FQDN or a valid address literal. Is there any way to set this
value? Checking this value can help in fighting spam so there should be an
easy way for a proper setting.
thanks
 
B

Brian Tillman

zbynek said:
If there is a way to instruct the client to use a name like "EHLO
mobileuser.company.com" having a valid A record in the company.com
zone, the message would pass to the server and be regularly processed.
Do this in the TCP/IP properties for your connection. Right-click My
Network Places and choose Properties. Right-click your Internet connection
and choose Properties. Select the "Internet Protocol (TCP/IP) protocol and
click Properties. Click Advanced. select the DNS tab and at the bottom,
enter the value you want in the "DNS suffix for this connection" field.
 
G

Guest

Unfortunately this setting have no impact on the EHLO string, still uses just
the machinename instead of machimename.domainname. (BTW the same apply for
the outlook expres)

zbynek
 
G

Guest

This is an issue for me as well. Did you find an answer elsewhere since this
post kind of reached a dead end??

Ken
 
B

Brian Tillman

KenM said:
This is an issue for me as well. Did you find an answer elsewhere
since this post kind of reached a dead end??
Assuming Windows XP, I believe you can force it by right-clicking My
Computer, choosing Properties, selecting the Computer Name tab, clicking
Change, then More and specifying it in the "Primary DNS suffix of this
computer" field.
 
G

Guest

Hi Brian...

I tried that after reading your earlier post, but I got the same result as
zbynek mentioned in his earlier post, which was that it didn't change
anything.

I have been reading about this non-compliance with RFC 2821 issue in various
other places on the internet and the only real fix that I have found so far
seems to be to switch to a different email client that is complient.

Ken
 
Ad

Advertisements

G

Guest

Hi Ken,

Exactly, the problem is, that it might not be always easy to persuade users
to use different client, or, worse, some applications may not cooperate
smoothly with them. In such a case there might be a workaround in running
some lightweight smtp server locally (obviously a different port) that would
serve as a gateway to the outer world. Obviously this is far more complicated
than adding some string in the registry, but it might work provided there is
such a beast found out in the freeware domain.

zbynek
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top