Home networking with a wired and wireless network


G

Guest

Okay, here we go. I have a wired network in my house and a wireless network
through a linksys router. I can't see the other computers on my wired
network and thus can't seem to share printers and such.

Where the cable comes into the house it goes into the modem first, then a
gateway to the bedrooms. In the office the connection goes into the linksys
router and from there into the desktop. One bedroom uses the wired network
and can access the internet, but I can't see the other wired one when I look
on either of them. I use 2 laptops wirelessly and they both function just
fine accessing the internet, but I would also like to be able to share the
printer that is in the office connected to the desktop.

Hopefully someone can help me.
 
Ad

Advertisements

J

Jim

Roelant said:
Okay, here we go. I have a wired network in my house and a wireless
network
through a linksys router. I can't see the other computers on my wired
network and thus can't seem to share printers and such.

Where the cable comes into the house it goes into the modem first, then a
gateway to the bedrooms. In the office the connection goes into the
linksys
router and from there into the desktop. One bedroom uses the wired
network
and can access the internet, but I can't see the other wired one when I
look
on either of them. I use 2 laptops wirelessly and they both function just
fine accessing the internet, but I would also like to be able to share the
printer that is in the office connected to the desktop.

Hopefully someone can help me.
What are the IP addresses of all of these items?

I have a setup somewhat like yours, but my connection goes from the DSL
modem to a Linksys router. All of the systems connect to the router. The
router furnishes all IP addresses hence they are part of the same subnet.

Jim
 
L

Lem

Roelant said:
Okay, here we go. I have a wired network in my house and a wireless network
through a linksys router. I can't see the other computers on my wired
network and thus can't seem to share printers and such.

Where the cable comes into the house it goes into the modem first, then a
gateway to the bedrooms. In the office the connection goes into the linksys
router and from there into the desktop. One bedroom uses the wired network
and can access the internet, but I can't see the other wired one when I look
on either of them. I use 2 laptops wirelessly and they both function just
fine accessing the internet, but I would also like to be able to share the
printer that is in the office connected to the desktop.

Hopefully someone can help me.

The description of your physical layout is missing some information, but
it sounds to me as if you may have multiple routers and this multiple
subnets. One thing you might do is, on each computer, open a command
prompt window by going to Start > Run and typing "cmd.exe" (without
quotes) and clicking OK. In the window that opens, type "ipconfig /all"
(without quotes) and press Enter.

The IP address for each computer (at least for the network interface
that's being used - wireless for the laptops) should have the first 3
octets the same. For example, 192.168.1.x, where the x can be any
number from 2 to 255. If the first 3 octets are not the same, the
computers won't see each other.

Going back to your physical setup:
- what is the "gateway" to the bedrooms and how is it connected to the
modem?
- what is connected to the router in the office, and which jack on the
router is it connected to?
 
G

Guest

Lem, thanks for responding. I thought it is called a gateway, I just looked
on the Linksys site and it is called "EtherFast® Cable/DSL Router with 4-Port
Switch." This is what is connected to the modem and then connects to 4 of
the rooms in my house (wired). In one of these rooms I have a connection to
a laptop and in another room a connection to a Linksys wireless router,
"Wireless-G Broadband Router." This router connects through a cable to my
desktop and I have 2 other laptops that connect to the internet wirelessly.
Every one of these 4 devices connect to the internet perfectly. However, I
am trying to set all of them up to use the printer that is connected to the
desktop and have no clue how to do this. Any help is greatly appreciated.
 
J

Jack \(MVP-Networking\).

Hi
If the second Router is connected to the first one through its WAN
(Internet) port you created double Routing and two independent Networks, and
thus you can not share resources.
The second Router has to be connected as a Switch with an Access Point. like
this.
Wireless Router as an Access Point - http://www.ezlan.net/router_AP.html
Jack (MVP-Networking).
 
Ad

Advertisements

L

Lem

Roelant said:
Lem, thanks for responding. I thought it is called a gateway, I just looked
on the Linksys site and it is called "EtherFast® Cable/DSL Router with 4-Port
Switch." This is what is connected to the modem and then connects to 4 of
the rooms in my house (wired). In one of these rooms I have a connection to
a laptop and in another room a connection to a Linksys wireless router,
"Wireless-G Broadband Router." This router connects through a cable to my
desktop and I have 2 other laptops that connect to the internet wirelessly.
Every one of these 4 devices connect to the internet perfectly. However, I
am trying to set all of them up to use the printer that is connected to the
desktop and have no clue how to do this. Any help is greatly appreciated.
Home routers, such as the 2 you have, combine a switch and a router. In
addition, the 2nd one adds a wireless access point.

What you want to do is to disable the router portion of the WirelessG
unit, and use only its switch and wireless access point.

I suggest that you print out the following and read it through before
you start changing things. The following assumes that the routers are
at their default settings.

First, to avoid confusion, disconnect from the WirelessG unit the cable
that comes from the EtherFast router.

You need to know what range of IP addresses is used by the Etherfast
router. If it is a Linksys, it probably is 192.168.1.x, but just to be
sure, go to the laptop that is directly wired to the Etherfast router
and run the ipconfig /all command as described in my first post. You
should see the IP address of the laptop (which I am guessing will be
192.168.1.100) and you should also see entries for "Default Gateway" and
"DHCP Server." These probably will be the same, and probably will be
192.168.1.1

Assuming that the Etherfast router is at 192.168.1.1, do the following:

Using your desktop, which connects to the WirelessG unit with a cable,
access its configuration utility. You should be able to do this by
entering 192.168.1.1 in a browser. On the Setup | Basic Setup screen,
change the router's "Local IP address" from 192.168.1.1 to 192.168.1.2.
Then disable the router's DHCP server. Then click "save settings."
Note that once you do this, you will have to reconnect to the WirelessG
unit's configuration utility by entering 192.168.1.2 in your browser.
You might want to put that on a label and tape it to the router so you
don't forget.

Now connect the Ethernet cable from the 1st router to one of the 4 LAN
jacks on the WirelessG unit, not to its WAN or "Internet" jack.

Re-boot your desktop. Run ipconfig /all. You should see the DHCP
server and Gateway as 192.168.1.1 and the desktop's IP address as
192.168.1.x, where x is different than the IP address of the first
laptop. You can now fire up the wireless units and they should connect
as well. All computers should show the same DHCP server (192.168.1.1)
and Default Gateway (also 192.168.1.1). Each of the computers should
have an IP address of the form 192.168.1.x, where x is probably 100,
101, 102, 103, and so on (unless you changed the default).

Now all you have to do is to setup file and printer sharing. Here's a
cut-n-paste from MS-MVP Malke that explains how to do it:

Run the Network Setup Wizard on all computers, making sure to enable
File & Printer Sharing, and reboot (also be sure to select the option
that each computer connects to the Internet "through a residential
gateway"). The only "gotcha" is that this will turn on the XPSP2 Windows
Firewall. If you aren't running a third-party firewall or have an
antivirus with "Internet Worm Protection" (like Norton 2005/06) which
acts as a firewall, then you're fine. If you have third-party firewall
software, configure it to allow the Local Area Network traffic as
trusted. I usually do this with my firewalls with an IP range. Ex. would
be 192.168.1.0-192.168.1.254. Obviously you would substitute your
correct subnet.

If one or more of the computers is XP Pro:

a. If you need Pro's ability to set fine-grained permissions, turn off
Simple File Sharing (Folder Options>View tab) and create identical user
accounts/passwords on all computers.

b. If you don't care about using Pro's advanced features, leave the
Simple File Sharing enabled.

Simple File Sharing means that Guest (network) is enabled. This means
that anyone without a user account on the target system can use its
resources. This is a security hole but only you can decide if it matters
in your situation.

Then create shares as desired. XP Home does not permit sharing of users'
home directories (My Documents) or Program Files, but you can share
folders inside those directories. A better choice is to simply use the
Shared Documents folder.

If that doesn't work for you, here is an excellent network
troubleshooter by MVP Hans-Georg Michna. Take the time to go through it
and it will usually pinpoint the problem area(s) -
http://winhlp.com/wxnet.htm

If you still have problems, post back with the ipconfig /all information
for each of the computers.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top