Help! USB Device is mounted but unaccessable


R

Robert Powell

This is a weird one, at least for me - I've searched the archives of this
and windowsxp.general and can't get any answers so hopefully those with
almost infinitely superior knowledge of external storage devices and WinXP
vagaries - that'll be you then *smiles hopefully*- will have an answer.

I've ebayed a 4GB USB MP3/Mp4 player, which is extremely nice - it comes
with quite a few files which aren't so nice (seriously who listens to Barbie
Girl and Say you Say me?) and a host of problems.

I'm running a Dell Dimension 4700, (Pentium 4) with 1 GB of ram and am using
WinXP service pack2 with McAfee Firewall.

When I plug the player into a USB slot (I've got both usb 2 and 1.1 slots on
my system, and get the same result from all of them) WinXP recognise the
player as an external USB storage device, loads a host of generic drivers
and gives the drive a letter "Removable Drive G:" which is all well and
good.

However when I try to open or explore the drive, WinXP tells me the drive
isn't formatted and asks if I'd like to format it. Happy to lose
barbiegirl.mp3, I click yes and there my problems begin.

Instead of 4GB it shows 4MB

It only allows FAT formatting

It only allows Default allocation size

Figuring if I can at least format the drive, I might be able get it to
recognise the full 4GB, I click Start and it tells me: "Windows was unable
to complete the format." Followed by the legend "The disk in drive G cannot
be formatted"

Okay - thinks I - I'll checkout disk management, where I can see the
following values:

Volume G:
Layout = Partition
Type = Blank
File System = (nothing, there is no entry)
Status = Healthy
Capacity = 4MB
Free Space = 4MB
% Free = 100%
Fault Tolerance and Overhead = 0%.

Which is just duff info! There is certainly less than 100% free space on the
drive - the example files on the drive are close to 30MB.

There should be 4GB on the thing not 4MB - again storing 30mb of files on a
4mb drive is a good trick if you can do it!

And why is there no File system of any kind?

There is a CD of drivers - Win98 drivers that is - but in a futile attempt
to get Window's to recognise and access the player/drive I've tried
installing them and it comes with a Player Disk Tool and a Player Update
tool.

The disk tool, like WinXP, only recognises 4MB and when formatting says
there is a Total disk space of, 4169728 bytes, 0 system files, 0 bad
sectors, available disk space of 4169728 bytes, each allocation unit is 2048
bytes total allocation units 2036.

All of which is utter nonsense because as soon as I try the player . . .
blasted barbiegirl.mp3 is still there, and indeed the entire drive is
untouched!

If I run the update it tells me that; "Removable disk is busy, please run
the program after waiting a moment."

The player was sourced from Hong Kong so the documentation is translated
from Chinese - funny and diverting as all heck with phrases such as "The
modification that makes the oneself to correspond clicks the next move
behind:" but is as helpful as a gearbox on a pogo-stick!

The player itself works great and is a serious bit of kit - cheaper, smaller
and with more features than an IPOD nano - Voice Recording, FM Radio, MP3
playback, Video Playback, Games, all look, sound and work wonderfully but
unfortunately they're the ones that came with the player and I can't access
the drive to change anything.

Any ideas of how to get to the contents of the drive/player without using a
large hammer, or why I'm getting such erroneous partial info from WinXP
would be gratefully received.

Regards

Bobble
 
Ad

Advertisements

R

Robert Powell

Right sussed it - the new player/drive had a hidden menu which set it's
detection/online value to encrypted - working a treat now.

Still like to know why WinXp picked up a partial result though.

Cheers

Bob
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top