Getting rid of boot partition menu


E

Ed

In a botched attempt to resolve some problems with XP Pro I created
another partition on my
primary master HDD. This created a boot menu that comes up during
start-up, asking me which
Windows XP I want to boot to. If I'm fast enough to select the second
choice in the menu it
boots successfully to my original XP installation, which now works
fine. So, to get rid
of the second boot I simply deleted the partition, using Partition
Magic. The only problem is
it still offers me the menu at start-up.

The C:\boot.ini file contains:

[boot loader]
timeout=1
default=signature(43009b61)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
signature(43009b61)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft
Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect /NoExecute=OptOut

I suspect I solve the problem by either removing this file entirely,
or editing it somehow. But, I though it wise to
seek some advice before proceeding. Am I on the right track?

TIA

Ed
 
Ad

Advertisements

N

Nepatsfan

Ed said:
In a botched attempt to resolve some problems with XP Pro I created another
partition on my
primary master HDD. This created a boot menu that comes up during start-up,
asking me which
Windows XP I want to boot to. If I'm fast enough to select the second choice
in the menu it
boots successfully to my original XP installation, which now works fine. So,
to get rid
of the second boot I simply deleted the partition, using Partition Magic. The
only problem is
it still offers me the menu at start-up.

The C:\boot.ini file contains:

[boot loader]
timeout=1
default=signature(43009b61)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
signature(43009b61)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect /NoExecute=OptOut

I suspect I solve the problem by either removing this file entirely, or
editing it somehow. But, I though it wise to
seek some advice before proceeding. Am I on the right track?

TIA

Ed


First, go to Control Panel and double click the System Icon.
In the System Properties sheet, click on the Advanced tab.
On the Advanced page, hit the Settings button in the Startup and Recovery
section.
This should launch the Startup and Recovery dialog.
Click the down arrow in the Default operating system box and highlight the
second entry.
Click OK.
Restart your computer and see if it boots into the good XP installation without
you having to make a selection.

Next, go to Start -> Run and enter msconfig in the Open box.
In the System Configuration Utility, click on the BOOT.INI tab.
On the BOOT.INI page, hit the Check all boot paths button.
You should be offered the option to delete this entry from your Boot.ini file.

signature(43009b61)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect

Take Windows up on the offer and you should now be able to start your computer
and boot directly into Windows.

Note: If you go back to Start -> Control Panel -> System -> Advanced -> Startup
and Recovery and hit the Edit button, your Boot.ini file should now look like
similar to this.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional"
/NOEXECUTE=OPTIN /FASTDETECT

Good luck

Nepatsfan
 
E

Ed

Nepatsfan said:
Ed said:
In a botched attempt to resolve some problems with XP Pro I created
another partition on my
primary master HDD. This created a boot menu that comes up during
start-up, asking me which
Windows XP I want to boot to. If I'm fast enough to select the
second choice in the menu it
boots successfully to my original XP installation, which now works
fine. So, to get rid
of the second boot I simply deleted the partition, using Partition
Magic. The only problem is
it still offers me the menu at start-up.

The C:\boot.ini file contains:

[boot loader]
timeout=1
default=signature(43009b61)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
signature(43009b61)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft
Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect /NoExecute=OptOut

I suspect I solve the problem by either removing this file
entirely, or editing it somehow. But, I though it wise to
seek some advice before proceeding. Am I on the right track?

TIA

Ed


First, go to Control Panel and double click the System Icon.
In the System Properties sheet, click on the Advanced tab.
On the Advanced page, hit the Settings button in the Startup and
Recovery section.
This should launch the Startup and Recovery dialog.
Click the down arrow in the Default operating system box and
highlight the second entry.
Click OK.
Restart your computer and see if it boots into the good XP
installation without you having to make a selection.

Next, go to Start -> Run and enter msconfig in the Open box.
In the System Configuration Utility, click on the BOOT.INI tab.
On the BOOT.INI page, hit the Check all boot paths button.
You should be offered the option to delete this entry from your
Boot.ini file.

signature(43009b61)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft
Windows XP Professional" /fastdetect

Take Windows up on the offer and you should now be able to start
your computer and boot directly into Windows.

Note: If you go back to Start -> Control Panel -> System ->
Advanced -> Startup and Recovery and hit the Edit button, your
Boot.ini file should now look like similar to this.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /NOEXECUTE=OPTIN /FASTDETECT

Good luck

Nepatsfan


I've gone through the above steps, but not totally happy with the
result. Now at startup I get a dialog reminding me that
I made the change and recommending that I change it back the way it
was. Then it pops open the System Config tool
just to make it convenient for me to do so. Although there is a check
box that would allow me to not get the message again,
I can see that this fix is using something intended as a temporary
debugging technique, i.e., skipping parts of the boot sequence,
rather than permanently changing it.

Any other ideas?

Thanks again.

Ed
 
Ad

Advertisements

N

Nepatsfan

Ed said:
Nepatsfan said:
Ed said:
In a botched attempt to resolve some problems with XP Pro I created another
partition on my
primary master HDD. This created a boot menu that comes up during start-up,
asking me which
Windows XP I want to boot to. If I'm fast enough to select the second choice
in the menu it
boots successfully to my original XP installation, which now works fine. So,
to get rid
of the second boot I simply deleted the partition, using Partition Magic.
The only problem is
it still offers me the menu at start-up.

The C:\boot.ini file contains:

[boot loader]
timeout=1
default=signature(43009b61)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
signature(43009b61)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect /NoExecute=OptOut

I suspect I solve the problem by either removing this file entirely, or
editing it somehow. But, I though it wise to
seek some advice before proceeding. Am I on the right track?

TIA

Ed


First, go to Control Panel and double click the System Icon.
In the System Properties sheet, click on the Advanced tab.
On the Advanced page, hit the Settings button in the Startup and Recovery
section.
This should launch the Startup and Recovery dialog.
Click the down arrow in the Default operating system box and highlight the
second entry.
Click OK.
Restart your computer and see if it boots into the good XP installation
without you having to make a selection.

Next, go to Start -> Run and enter msconfig in the Open box.
In the System Configuration Utility, click on the BOOT.INI tab.
On the BOOT.INI page, hit the Check all boot paths button.
You should be offered the option to delete this entry from your Boot.ini
file.

signature(43009b61)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect

Take Windows up on the offer and you should now be able to start your
computer and boot directly into Windows.

Note: If you go back to Start -> Control Panel -> System -> Advanced ->
Startup and Recovery and hit the Edit button, your Boot.ini file should now
look like similar to this.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /NOEXECUTE=OPTIN /FASTDETECT

Good luck

Nepatsfan


I've gone through the above steps, but not totally happy with the result. Now
at startup I get a dialog reminding me that
I made the change and recommending that I change it back the way it was. Then
it pops open the System Config tool
just to make it convenient for me to do so. Although there is a check box that
would allow me to not get the message again,
I can see that this fix is using something intended as a temporary debugging
technique, i.e., skipping parts of the boot sequence,
rather than permanently changing it.

Any other ideas?

Thanks again.

Ed

Using msconfig is the easiest and safest way to remove an incorrect entry from a
boot.ini file. The changes it makes to the file are permanent. That's why you
end up with "Use Modified BOOT.INI" selected on the General page. The original
file has been replaced.

If you don't want to use msconfig to fix your boot.ini file, you will have to
manually edit the file to remove the problem entry. Take a look at this article
for more info.

How to edit the Boot.ini file in Windows XP
http://support.microsoft.com/kb/q289022/

Boot.ini should end up looking like this.

[boot loader]
timeout=1
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /fastdetect /NoExecute=OptOut

Keep in mind that if you make a mistake editing your boot.ini file you will need
to use your XP installation CD to run the Recovery Console to fix the problem.

Good luck

Nepatsfan
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Dual boot help please (Doing it right?). 10
Removing Dual Boot Options 4
(Again) A Dual Boot Question? 4
HAL.dll 15
Boot Problems 2
Dual boot XP 6
Boot.ini problems 6
How to boot to cd? 3

Top