FSX & Vista


Chip Shapiro

Operating System : Vista Ultimate

7900 GTX Video Card

When you try to bring up FSX it just flashes uncontrollably. It's both the
sound & the video. I made no changes during setup, I just ran the program.
I figured I could make the changes later.

I have a friend with a similar machine, same operating system with a little
lesser video card doing the exact same thing. This is why I installed this
program ahead of others to see what would happen on my system.

I've looked through the messages and can't see anyone else having this

Any ideas?

I have my desktop @ 1600 x 1250. I have not made any changes to FSX in
attempt to fix this. Do you think a lower resolution would help, although
it probably wouldn't help the audio, but that could be a reset of the video?



Chip Shapiro

I just installed Vista this morning and got the drivers from Nvidia.com at
that time. The sound drivers I will have to check to see if they are the
latest, It is onboard. Thanks for the AVSIM idea, I was fumbling around MS's
site. Dummy me! :)



A lot of people are complaining about onboard sound with Vista. I think the
biggest problem is the drivers. Try disabling your sound in the BIOS boot
the computer and see if you can get into FSX. If you can at that point it
would definitely narrow it down to being a sound problem because you say you
already have the new nvidia video drivers. Other than that just keep
searching I am sure other people have had the same problem and found a

Chip Shapiro

Got it.

It's something to do with the Nvidia drivers. I disabled the sound and that
did not fix it so I changed from Dual View to Clone and the problem is gone.
That is not the only issue we have found with the driver as it won't let you
configure the desktop indenpendant from on another like you could
previously. It in the Description on the Control panl page for Nvidia, but
there is no option..

Thanks for your suggestions. I guess it's CLONE view for now if you want to
run FSX (on these two machines anyway)



Was going to suggest If you had your system set up for dual monitor, to
disable your secondary monitor. I have had this same problem using an ati
radeon x1600.


Yeah it doesn't support dual monitors. I had mine setup previously and got
the exact same flashing, diabled one and haven't had an issue since. I had it
cloned but got dizzy so i recommend the disabling option

Martin Racette

Received it today, and it's wonderful, I'm using Nvidia's 8800GTS and Vista


Paul Graham

I had the same flashing problem - Ultimate, two monitor setup.
I found that when it first loads, and gets to around 82% , you should
ALT-TAB to go back to the desktop. FSX will bring itself forward again and
there's no flashing.
It will start its silly business again if you go into Map or other setup
change menus within FSX, but if you do the ALT-TAB again....wait a couple of
seconds then ALT-TAB back into FSX I found everything is fine again.... and
both monitors work fine.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question