Form Combo incorrectly rounding



I have a field that is named 3-Gauge. Type=Number, Size=Single (I also tried
double), Format=Standard, Decimals=4. The values appear correctly in the
underlying query (e.g. 0.0160), but the combo rounds everything up (e.g.
0.02). I have tried using Standard, and Fixed format for the Combo
properties, and have the Decimal Places set to 4. But it still displays
0.02. If I do a setvalue macro to populate a corresponding unbound field on
the form, it populates correctly. It just won't display in the combo without

Thanks for your help.


The values appear correctly in the underlying query (e.g. 0.0160)
A couple of things do not match in your post. If it is a number field then
it would not display a trailing zero in the query unless you format it and
that changes it to a string.
How do you move it between the form and the table if unbound on the form?

What is the source for the combo? Is it coming from some text source?

Take a look directly in the table and see what is in the number field.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question