Force Drive Letters


G

Guest

I have a problem with Windows XP, I have changed the drive letters for my CD
and DVD devices to "V" and "W" to avoid the constant re-lettering of these
drives due to the addition of USB memory devices or flash memory cards.
For some reason, the next re-start after using a removable drive, Windows XP
seems to continually forget the letters that I have reassigned the CD/DVD
drives, and it reassigns new letters to them again, to whatever configuration
it thinks appropriate at that moment (the letters vary). The end result is
that my CD-ROM and DVD-ROM always seemed to be labeled with a different drive
letter. This moving target of changing drive letters is causing other
programs to have problems since they never seem to know where to find the
constantly moving optical drives.
How do I force Windows keep the drive letters that I have assigned to these
devices?
 
N

neil

You should be able to set the drive letter in disk management. Is that what
you have tried to use, once set they should not change.

Neil
 
Ad

Advertisements

R

Richard Urban

Change the drive letters to what you want and immediately reboot. This locks
the change in place. If you add other devices before you reboot - all bets
are off.

This has always worked on "any" system I have worked on (many).

--


Regards,

Richard Urban
Microsoft MVP Windows Shell/User

Quote from George Ankner:
If you knew as much as you think you know,
You would realize that you don't know what you thought you knew!
 
G

Guest

I set the drive letters in disk management, but they seem to reset themselves
whenever Windows sees fit.
 
G

Guest

I thought that worked too, but not in this case. The drive letters remain,
until I add a removable drive, then they change. They change again when I
remove the temporary drive, and do not return to the set drive letters.
There does not seem to be a way to make the settings permanent.
 
N

neil

This is strange because I know it works because that's what I have done. The
only difference being my removable drives are set at the end with the CD &
DVD drives as E & F. (hard drives C & D). Do you also set the removable
drive/s to specified letters when they are plugged in.??

Neil
 
R

Richard Urban

Place the CD and DVD drives at the END of the alphabet, where they are out
of the way.

--


Regards,

Richard Urban
Microsoft MVP Windows Shell/User

Quote from George Ankner:
If you knew as much as you think you know,
You would realize that you don't know what you thought you knew!
 
Ad

Advertisements

U

Uncle Grumpy

Richard said:
Place the CD and DVD drives at the END of the alphabet, where they are out
of the way.
OP did that and said so in the original post.

NEXT?
 
R

Richard Urban

Yep. I read and forgot that.

--


Regards,

Richard Urban
Microsoft MVP Windows Shell/User

Quote from George Ankner:
If you knew as much as you think you know,
You would realize that you don't know what you thought you knew!
 
G

Guest

When I plug the removable drive in, Windows XP assigns drive letters -
apparently the first available - but not always. I can change this in the
manage section, but it will change again once I eject the drive.

What I think I need is a registry tweek, that will force the drive letter
each time. I just can't seem to find one that applies to Windows XP
 
P

Pat

I have the same problem and I note that if I switch to the show_nonpresent view in device manager
and remove the *paired* CD drives I see there (one "real" and one nonpresent) then when I restart
all seems well (the drives are redetected, reinstalled and only the real ones appear in device
manager show_nonpresent view.) But when I restart again the drives are redetected a *second* time
and now I am back with the paired drive icons and they will not stay set as I wish (V and W drive
co-incidentally!)

I used this post from Uwe Sieber to help me (I will check out the second suggestion next i.e. check
my master/slave jumpers):

"Maybe your XP needs a rigorous drive and mount point
cleanup:

Create a system restore point first...

To make the device manager show non present devices, we
need the environment variable DEVMGR_SHOW_NONPRESENT_DEVICES
set to "1".
The easiest way is to start the device manager using a
command script. Put the following two lines into Notepad
and save as DevMgmtX.cmd

set DEVMGR_SHOW_NONPRESENT_DEVICES=1
devmgmt.msc

Start the saved DevMgmtX.cmd, the device manager comes up.
Select 'View' -> 'Show hidden devices'.
Now delete all non present stuff (translucent icons)
under 'drives' and 'storage volumes'.

Then open Regedit and go to
HKEY_CURRENT_USER\Software\Microsoft\
Windows\CurrentVersion\Explorer\MountPoints2
Delete or rename the whole MountPoints2 hive.

Then go to
HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
Delete or rename the whole MountedDevices hive.

Reboot and pray :)

Then Windows will reassingn all letters and maybe they
become as persistent as they should be...


Greetings from Germany

Uwe"

His second suggestion after the first did not work:

"Maybe it's a hardware problem with your CD drives. You could
try to change their master/slave setting. Or attach them
to a PCI controller card like a good old Promise Ultra-33
or Ultra-66 which you can get cheap at eBay because of their
128GB limit...

No more ideas...

BTW: There is another tread here discussing the same problem
("Force Drive Letters", started on 13th Feb.).


Greetings from Germany

Uwe"
 
Ad

Advertisements

G

Guest

IT WORKS!!!! I tried the first solution, and the computer re-started with
reassigned drive letters for all of my drives. Once I re-assigned them to
what I wanted, they seem to be staying this time.

Thank you very much!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Force Drive Letters 0
Force Drive Letters ?? 8
How to force drive letters 4
Drive letter 4
Drive Letters 4
Drive Letters 1
Drive Letters 2
Drive Letters 4

Top