FBReseal FP2007 and MSDTC/COM+, & IIS


G

Guest

Hi All.

I am running across an issue related with fbreseal and its effect on MSDTC,
COM+ and IIS.
We use IIS on the target for administration, among other things

I use fbreseal manually using: -autologon -keepdomain -keepnet -keepuser
This generates a unique computername, which is fine, and the desired approach

However, it appears that the resealing process removes and tries to
reinstall MSDTC. The uninstallation works OK, but then the MSDTC cannot be
reinitialized / installed, and is shown as such in the event viewer. The next
items are then captured in the event viewer:


Source: MSDTC Client

Failed to initialize the needed name objects. Error Specifics:
d:\qxp_slp\com\com1x\dtc\dtc\msdtcprx\src\dtcinit.cpp:215, Pid: 1952
No Callstack,
CmdLine: C:\Windows\system32\dllhost.exe
/Processid:{02D4B3F1-FD88-11D1-960D-00805FC79235}

Source: COM+

The run-time environment has detected an inconsistency in its internal
state. This indicates a potential instability in the process that could be
caused by the custom components running in the COM+ application, the
components they make use of, or other factors. Error in
d:\qxp_slp\com\com1x\src\comsvcs\crm\recoveryclerk2.cpp(1783), hr = 8004d027:
Recover

Source: IISADMIN

IISADMIN service was unable to update the activation identity for all IIS
COM+ applications. Some IIS applications may fail to function.

This basically then hoses the website running on the target.

I have tried using the msdtc -install routines, discovered in related
threads, however the issue is not resolved by using those methods.

The problem also occurs when using, simply fbreseal -keepall.

Note: The resealer in FP2007 also displays a "Resealing in Progress..."
after the system reboots. This is different behavior than that found in SP2.

Any hints here are most appreciated. I am suspecting a missing component
perhaps? RPC named service maybe?
 
Ad

Advertisements

G

Guest

Getting closer to resolve here.

Appears that Server Service (component: File sharing) needs to be in place
for MSDTC to reinstall after fbreseal. I had eliminated this component all
together in my build. FBA ran OK, and everything is fine (MSDTC, IIS, COM+
and all) UNTIL the image is resealed in the absence of sever service.

Sean or KM, any thoughts here?
 
Ad

Advertisements

S

Sean Liming \(eMVP\)

None from me. I know there was an IIS issue with the System Cloning tool,
but I thought it was solved some time ago. KM might have an answer, but I
have not seen him lately in the Newsgroup.

The Update Rollup 1.0 has some strange behaviour with the System Cloning
tool. It seems to work okay, but the message boxes are wrong. If you are not
using UR 1.0 give it a try and see if it causes the same issue.

Regards,

Sean Liming
www.sjjmicro.com / www.seanliming.com
Book Author - XP Embedded Advanced, XP Embedded Supplemental Toolkit
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top