Excel is not copying my formulas correctly when I drag them down


S

SV

Hi everyone,

My formulas were working just fine until today. I think
some setting somewhere in Excel has gone haywire, but I
don't know what or how.

I've got a column of data and have a column next to it
that I'm using as a running total. When I drag the formula
down in the running total it is showing the correct field
references in all the fields after I've dragged it down,
however it is producing unexpected results. i.e it is
showing the same number in every field in that column as
the result instead of the result of the actual formula.
Has anyone else had this problem? What did you do to fix
it?
 
Ad

Advertisements

A

Arvi Laanemets

Hi


Or calculation is set to manual (Tools.Options.Calculation). You can easily
test it, pressing F9
 
G

Guest

Hi Norman,

No that is not the problem at all.

Here is an example!
Debits Credits Balance
$307.28 $307.28
$514.81 $822.09
$13.38 $835.47
$16.14 $851.61
$114.22 $965.83
$4.41 $970.24
$44.18 $1,014.42
$4.93 $1,019.35
$228.80 $1,248.15
$17.04 $1,265.19

Now that above is the result I am wanting! So that it is a
running total of the debits column minus the credits
column. If we call Debits Column A, Credits Column B and
the balance column C, and I was trying to get the second
row's result to be $822.09 I would put in the formula
=C1+A2-B2. I would then drag the formula down so that it
will update the rest of Column C.

Now, that always worked fine for me until today. When you
look at the formulas it puts into the remaining fields in
Column C, they appear to be correct (ie, the next line
would be =C2+A3-B3 and then the next one =C3+A4-B4 and so
on)however, it keeps giving the result of $822.09 on every
line regardless of the formula. It's very peculiar!

I hope that makes a bit more sense now...
 
J

JE McGimpsey

Tools/Options/Calculate select the Automatic radio button.
 
Ad

Advertisements

Joined
Apr 6, 2016
Messages
1
Reaction score
0
For Microsoft Excel 2010,
go to 'Formulas' tab, then under the Calculation group, located at the end of the ribbon, click 'Calculation Option' and select 'Automatic'. :)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top