Excel File won't Import into Access


Roger Converse


I reference an object (Monarch) to create a table that I then want to import
into my Access Database. The file is outputted by default to a .xls
extension and Microsoft Excel 2.1 Worksheet (I am using Office 2003). When
the below command runs, I receive an error indicating that the file is not in
expected format. I have tried all the "TypeExcel#"'s and haven't had any
luck. Any suggestions?

DoCmd.TransferSpreadsheet acImport, acSpreadsheetTypeExcel9,
"tblVendBO", strExportTable, -1

I also tried to rename the file into a .tab file, however, when I import
that file, it is all jibberish.

Thank you,

Jerry Whittle

acSpreadsheetTypeExcel9 is Excel XP/2002 and Excel 2003 if I remember

Possibly change it to acSpreadsheetTypeExcel3 which is an earlier version of
Excel and actually the default for TransferSpreadsheet. It might work better
with an Excel 2.1 file format.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question