Excel 2007 won't allow me to insert a row


D

David

I am new to Excel2007 although I have been using Excel for many years.

The problem I am having exists with only one Excel workbook file and
only in Excel2007, The problem exists if I save the file as a 'xlsx'
file or as a 'xls' file.

My problem workbook contains 6 sheets (tabs). It was originally
created on my old PC using Excel2000 and since transferred to my new
PC which has Excel2007. The worksheet is essentially a large database
with relatively few calculations. When I try to insert a row (HOME ->
Cell Menu -> Insert -> Insert Sheet Rows), I get the following nasty
gram: "Can't shift object off sheet". The problem also exists with
the same error message if I try to insert a column.

I have already looked at the bottom row. There is no garbage in it. I
have tried deleting all rows from the bottom row to the row just below
the last row with data. This has not helped.

This problem did not exist when I first moved the worksheet to my PC
with Excel2007. It is recent. I must have inadvertently changed an
option setting somewhere. The problem does not exist with all
Excel2007 worksheets, only this one.

I have only come up with one workaround - not a fix. I can save the
workbook as a 'xls' file, move it back to my old PC, use Excel2000 to
insert the row, & move it back to the new PC with Excel2007. Then
Excel2007 will recognize the new row although I still can't insert a
new row using Excel2007.

The problematic workbook only has 65636 rows, not the 1048576 expected
even when saved as a 'xlsx' file using Excel2007 probably due to the
fact Excel2000 created the workbook.

I would really appreciate it if someone could help me with this.
 
Ad

Advertisements

Ad

Advertisements

R

Rachel

Hi, I have been having this problem with Excel too. I have tried all of tips of here: http://support.microsoft.com/kb/211769 but have had no luck. I didn't have any comments in my spreadsheet but I added one and then deleted it straight away and then I was able to add rows again and all of my insert options were back and usable. I can't explain it at all but try to add and delete a comment to see if that works as it has worked for me and a colleague.

EggHeadCafe.com - .NET Developer Portal of Choice
http://www.eggheadcafe.com
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top