Excel 2007: macros disabled on new Vista machine


T

travis

My new Vista machine is giving me some grief over macros in Excel
2007.

I know how to create my own certificate and sign a macro, using the
management console I moved my certificate into trusted root
certificate authorities.

Excel refuses to run macros, even though it shows the certificate
there and says the certificate is "ok".

So I added the location which the spreadsheet is running in to trusted
locations.

It still refuses to run the macros.

So I turned off macro security altogether.

It STILL refuses to run the macros.

The design mode button in the developer group is greyed out, but when
I try to run the macro via the macros button it doesn't work again.

"Because of your security settings, macros have been disabled. To tun
macros, you need to reopen this workbook, and then choose to enable
macros. For more info seee help etc".

I've done that, and have followed the same procedures I've used
perfectly successfully on my XP machine. It just refuses to run the
macros.

Is this a known bug or is there something I need to do in Vista to
enable the macros?

I have no problem with other macro workbooks I've been using for a
while and I'm perfectly capable of following the sequential
instructions given in the help files, but nothing I do seems to work.
Still, I can't create any new macro enabled worksheets (.xlsm) and get
the macros to run. Why?

Travis
 
Ad

Advertisements

J

Jim Rech

This might be the issue:

http://www.rondebruin.nl/password2007.htm

--
Jim
| My new Vista machine is giving me some grief over macros in Excel
| 2007.
|
| I know how to create my own certificate and sign a macro, using the
| management console I moved my certificate into trusted root
| certificate authorities.
|
| Excel refuses to run macros, even though it shows the certificate
| there and says the certificate is "ok".
|
| So I added the location which the spreadsheet is running in to trusted
| locations.
|
| It still refuses to run the macros.
|
| So I turned off macro security altogether.
|
| It STILL refuses to run the macros.
|
| The design mode button in the developer group is greyed out, but when
| I try to run the macro via the macros button it doesn't work again.
|
| "Because of your security settings, macros have been disabled. To tun
| macros, you need to reopen this workbook, and then choose to enable
| macros. For more info seee help etc".
|
| I've done that, and have followed the same procedures I've used
| perfectly successfully on my XP machine. It just refuses to run the
| macros.
|
| Is this a known bug or is there something I need to do in Vista to
| enable the macros?
|
| I have no problem with other macro workbooks I've been using for a
| while and I'm perfectly capable of following the sequential
| instructions given in the help files, but nothing I do seems to work.
| Still, I can't create any new macro enabled worksheets (.xlsm) and get
| the macros to run. Why?
|
| Travis
 
Ad

Advertisements

T

travis


It does seem to be an issue with excryption and maybe its my
antivirus, as suggested by a MS knowledgebase article, as I don't seem
to have the same problem for any workbooks that are not password
protected.

I'm using x64 vista, so I've got options of using a 32 bit DWord and a
64 bit one. Which should I use?

Travis
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top