Error after installing July patches on two Advanced Server 2000


G

Guest

Can you please help with the following? We have just installed the July
security patches and are now getting an error.

We installed the July Windows security patches on two boxes with:
--Windows Advanced Server 2000 sp 4 with IIS 5
--.net version 1.1.4322.573.

This following error message is now occurring every few seconds in the
Application event viewer.
Event ID 1008: The Open Procedure for service "ASP.NET_1.0.3705.6060" in
DLL "C:\WINNT\Microsoft.NET\Framework\v1.0.3705\aspnet_isapi.dll" failed.
Performance data for this service will not be available. Status code
returned is data DWORD 0.

What needs to be done to fix either the error or the software causing it?

Thanks
 
Ad

Advertisements

K

Ken Zhao [MSFT]

Hello Scott,

Thank you for using newsgroup!

Based on my research, please try to disable the perfmon counters for
ASP.Net 1.0 by adding the following 2 registry keys:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP.NET_1.0.3705\Perfor
mance
"Disable Performance Counters"=dword:00000001

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP.NET\Performance
"Disable
Performance Counters"=dword:00000001

Thanks & Regards,

Ken Zhao

Microsoft Online Support
Microsoft Global Technical Support Center

Get Secure! - www.microsoft.com/security <http://www.microsoft.com/security>
====================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
====================================================
This posting is provided "AS IS" with no warranties, and confers no rights.





--------------------
| Thread-Topic: Error after installing July patches on two Advanced Server
2000
| thread-index: AcfVIu9pZwnCbN/yTN+7iPEqar1WNw==
| X-WBNR-Posting-Host: 207.46.193.207
| From: =?Utf-8?B?U2NvdHRILS0t?= <[email protected]>
| Subject: Error after installing July patches on two Advanced Server 2000
| Date: Thu, 2 Aug 2007 09:34:02 -0700
| Lines: 18
| Message-ID: <[email protected]>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2826
| Newsgroups: microsoft.public.win2000.advanced_server
| Path: TK2MSFTNGHUB02.phx.gbl
| Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.win2000.advanced_server:259
| NNTP-Posting-Host: tk2msftsbfm01.phx.gbl 10.40.244.148
| X-Tomcat-NG: microsoft.public.win2000.advanced_server
|
| Can you please help with the following? We have just installed the July
| security patches and are now getting an error.
|
| We installed the July Windows security patches on two boxes with:
| --Windows Advanced Server 2000 sp 4 with IIS 5
| --.net version 1.1.4322.573.
|
| This following error message is now occurring every few seconds in the
| Application event viewer.
| Event ID 1008: The Open Procedure for service "ASP.NET_1.0.3705.6060" in
| DLL "C:\WINNT\Microsoft.NET\Framework\v1.0.3705\aspnet_isapi.dll" failed.

| Performance data for this service will not be available. Status code
| returned is data DWORD 0.
|
| What needs to be done to fix either the error or the software causing it?
|
| Thanks
|
|
 
K

Ken Zhao [MSFT]

Hi Scott,

I am just writing to see how everything is going. If you have any updates
or need any further assistance on this issue, please feel free to let me
know.

Thanks & Regards,

Ken Zhao

Microsoft Online Support
Microsoft Global Technical Support Center

Get Secure! - www.microsoft.com/security <http://www.microsoft.com/security>
====================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
====================================================
This posting is provided "AS IS" with no warranties, and confers no rights.





--------------------
| X-Tomcat-ID: 54696215
| References: <[email protected]>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: (e-mail address removed) ("Ken Zhao [MSFT]")
| Organization: Microsoft
| Date: Fri, 03 Aug 2007 04:41:29 GMT
| Subject: RE: Error after installing July patches on two Advanced Server
2000
| X-Tomcat-NG: microsoft.public.win2000.advanced_server
| Message-ID: <[email protected]>
| Newsgroups: microsoft.public.win2000.advanced_server
| Lines: 69
| Path: TK2MSFTNGHUB02.phx.gbl
| Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.win2000.advanced_server:260
| NNTP-Posting-Host: TOMCATIMPORT1 10.201.218.122
|
| Hello Scott,
|
| Thank you for using newsgroup!
|
| Based on my research, please try to disable the perfmon counters for
| ASP.Net 1.0 by adding the following 2 registry keys:
|
|
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP.NET_1.0.3705\Perfor
| mance
| "Disable Performance Counters"=dword:00000001
|
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP.NET\Performance
| "Disable
| Performance Counters"=dword:00000001
|
| Thanks & Regards,
|
| Ken Zhao
|
| Microsoft Online Support
| Microsoft Global Technical Support Center
|
| Get Secure! - www.microsoft.com/security
<http://www.microsoft.com/security>
| ====================================================
| When responding to posts, please "Reply to Group" via your newsreader so
| that others may learn and benefit from your issue.
| ====================================================
| This posting is provided "AS IS" with no warranties, and confers no
rights.
|
|
|
|
|
| --------------------
| | Thread-Topic: Error after installing July patches on two Advanced
Server
| 2000
| | thread-index: AcfVIu9pZwnCbN/yTN+7iPEqar1WNw==
| | X-WBNR-Posting-Host: 207.46.193.207
| | From: =?Utf-8?B?U2NvdHRILS0t?= <[email protected]>
| | Subject: Error after installing July patches on two Advanced Server 2000
| | Date: Thu, 2 Aug 2007 09:34:02 -0700
| | Lines: 18
| | Message-ID: <[email protected]>
| | MIME-Version: 1.0
| | Content-Type: text/plain;
| | charset="Utf-8"
| | Content-Transfer-Encoding: 7bit
| | X-Newsreader: Microsoft CDO for Windows 2000
| | Content-Class: urn:content-classes:message
| | Importance: normal
| | Priority: normal
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2826
| | Newsgroups: microsoft.public.win2000.advanced_server
| | Path: TK2MSFTNGHUB02.phx.gbl
| | Xref: TK2MSFTNGHUB02.phx.gbl
microsoft.public.win2000.advanced_server:259
| | NNTP-Posting-Host: tk2msftsbfm01.phx.gbl 10.40.244.148
| | X-Tomcat-NG: microsoft.public.win2000.advanced_server
| |
| | Can you please help with the following? We have just installed the July
| | security patches and are now getting an error.
| |
| | We installed the July Windows security patches on two boxes with:
| | --Windows Advanced Server 2000 sp 4 with IIS 5
| | --.net version 1.1.4322.573.
| |
| | This following error message is now occurring every few seconds in the
| | Application event viewer.
| | Event ID 1008: The Open Procedure for service "ASP.NET_1.0.3705.6060"
in
| | DLL "C:\WINNT\Microsoft.NET\Framework\v1.0.3705\aspnet_isapi.dll"
failed.
|
| | Performance data for this service will not be available. Status code
| | returned is data DWORD 0.
| |
| | What needs to be done to fix either the error or the software causing
it?
| |
| | Thanks
| |
| |
|
|
 
T

Terence Culla

I am running Microsoft Framework 1.0(.3705.6018) on Win2000 (SP4). This
patch was applied through our lower testing levels resulting in this error.
While turning off Performance Counters for the ASP.NET_1.0.3705.6060 object
was an adequate enough resolution for our lower testing levels, it was not
satisfactory enough for Production which needs to be up 24/7 where the
Performance Counters are monitored by Microsoft Operations Manager.



Unable to find a better solution to this issue on any Internet forums or
newsgroups, I developed my own.



What appears happens under the Hotfix install is the ASP Performance
Counters for v1.0.3705.6018 are unloaded, aspnet_isapi.dll (v1.0.3705.6060)
is deployed and ASP Performance Counters for v1.0.3705.6060 are loaded.
However the load procedure reads from aspnet_perf.ini, which is not
updated/redeployed under the hotfix and so while the ASP Performance Objects
are registered but their Counters are not indexed by the perflib data
library.



To repair the ASP.NET_1.0.3705.6060 Performance Counters, take the following
steps on the affected servers:

From the CMD prompt, run unlodctr ASP.NET_1.0.3705.6060

Edit C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705\aspnet_perf.ini, replacing
..6018 with .6060.

Save and close file.

From the CMD prompt, run lodctr
C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705\aspnet_perf.ini



The fix developed unloads the bad ASP (v1.0.3705.6060) Performance Objects,
amends the aspnet_perf.ini file to contain the correct version number and
reloads the objects from the amended .ini file, which ensures that the
Counters are indexed.





Terence Culla

Web Developer/Deployment Specialist


"Ken Zhao [MSFT]" said:
Hi Scott,

I am just writing to see how everything is going. If you have any updates
or need any further assistance on this issue, please feel free to let me
know.

Thanks & Regards,

Ken Zhao

Microsoft Online Support
Microsoft Global Technical Support Center

Get Secure! - www.microsoft.com/security
<http://www.microsoft.com/security>
====================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
====================================================
This posting is provided "AS IS" with no warranties, and confers no
rights.





--------------------
| X-Tomcat-ID: 54696215
| References: <[email protected]>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: (e-mail address removed) ("Ken Zhao [MSFT]")
| Organization: Microsoft
| Date: Fri, 03 Aug 2007 04:41:29 GMT
| Subject: RE: Error after installing July patches on two Advanced Server
2000
| X-Tomcat-NG: microsoft.public.win2000.advanced_server
| Message-ID: <[email protected]>
| Newsgroups: microsoft.public.win2000.advanced_server
| Lines: 69
| Path: TK2MSFTNGHUB02.phx.gbl
| Xref: TK2MSFTNGHUB02.phx.gbl
microsoft.public.win2000.advanced_server:260
| NNTP-Posting-Host: TOMCATIMPORT1 10.201.218.122
|
| Hello Scott,
|
| Thank you for using newsgroup!
|
| Based on my research, please try to disable the perfmon counters for
| ASP.Net 1.0 by adding the following 2 registry keys:
|
|
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP.NET_1.0.3705\Perfor
| mance
| "Disable Performance Counters"=dword:00000001
|
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP.NET\Performance
| "Disable
| Performance Counters"=dword:00000001
|
| Thanks & Regards,
|
| Ken Zhao
|
| Microsoft Online Support
| Microsoft Global Technical Support Center
|
| Get Secure! - www.microsoft.com/security
<http://www.microsoft.com/security>
| ====================================================
| When responding to posts, please "Reply to Group" via your newsreader so
| that others may learn and benefit from your issue.
| ====================================================
| This posting is provided "AS IS" with no warranties, and confers no
rights.
|
|
|
|
|
| --------------------
| | Thread-Topic: Error after installing July patches on two Advanced
Server
| 2000
| | thread-index: AcfVIu9pZwnCbN/yTN+7iPEqar1WNw==
| | X-WBNR-Posting-Host: 207.46.193.207
| | From: =?Utf-8?B?U2NvdHRILS0t?= <[email protected]>
| | Subject: Error after installing July patches on two Advanced Server
2000
| | Date: Thu, 2 Aug 2007 09:34:02 -0700
| | Lines: 18
| | Message-ID: <[email protected]>
| | MIME-Version: 1.0
| | Content-Type: text/plain;
| | charset="Utf-8"
| | Content-Transfer-Encoding: 7bit
| | X-Newsreader: Microsoft CDO for Windows 2000
| | Content-Class: urn:content-classes:message
| | Importance: normal
| | Priority: normal
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2826
| | Newsgroups: microsoft.public.win2000.advanced_server
| | Path: TK2MSFTNGHUB02.phx.gbl
| | Xref: TK2MSFTNGHUB02.phx.gbl
microsoft.public.win2000.advanced_server:259
| | NNTP-Posting-Host: tk2msftsbfm01.phx.gbl 10.40.244.148
| | X-Tomcat-NG: microsoft.public.win2000.advanced_server
| |
| | Can you please help with the following? We have just installed the
July
| | security patches and are now getting an error.
| |
| | We installed the July Windows security patches on two boxes with:
| | --Windows Advanced Server 2000 sp 4 with IIS 5
| | --.net version 1.1.4322.573.
| |
| | This following error message is now occurring every few seconds in the
| | Application event viewer.
| | Event ID 1008: The Open Procedure for service "ASP.NET_1.0.3705.6060"
in
| | DLL "C:\WINNT\Microsoft.NET\Framework\v1.0.3705\aspnet_isapi.dll"
failed.
|
| | Performance data for this service will not be available. Status code
| | returned is data DWORD 0.
| |
| | What needs to be done to fix either the error or the software causing
it?
| |
| | Thanks
| |
| |
|
|
 
Ad

Advertisements

J

jb

this is the problem I'm having. Can you tell me exactly how to go about
changing the registry keys as you've indicated? thanks, jb

"Ken Zhao [MSFT]" said:
Hello Scott,

Thank you for using newsgroup!

Based on my research, please try to disable the perfmon counters for
ASP.Net 1.0 by adding the following 2 registry keys:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP.NET_1.0.3705\Perfor
mance
"Disable Performance Counters"=dword:00000001

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP.NET\Performance
"Disable
Performance Counters"=dword:00000001

Thanks & Regards,

Ken Zhao

Microsoft Online Support
Microsoft Global Technical Support Center

Get Secure! - www.microsoft.com/security <http://www.microsoft.com/security>
====================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
====================================================
This posting is provided "AS IS" with no warranties, and confers no rights.





--------------------
| Thread-Topic: Error after installing July patches on two Advanced Server
2000
| thread-index: AcfVIu9pZwnCbN/yTN+7iPEqar1WNw==
| X-WBNR-Posting-Host: 207.46.193.207
| From: =?Utf-8?B?U2NvdHRILS0t?= <[email protected]>
| Subject: Error after installing July patches on two Advanced Server 2000
| Date: Thu, 2 Aug 2007 09:34:02 -0700
| Lines: 18
| Message-ID: <[email protected]>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2826
| Newsgroups: microsoft.public.win2000.advanced_server
| Path: TK2MSFTNGHUB02.phx.gbl
| Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.win2000.advanced_server:259
| NNTP-Posting-Host: tk2msftsbfm01.phx.gbl 10.40.244.148
| X-Tomcat-NG: microsoft.public.win2000.advanced_server
|
| Can you please help with the following? We have just installed the July
| security patches and are now getting an error.
|
| We installed the July Windows security patches on two boxes with:
| --Windows Advanced Server 2000 sp 4 with IIS 5
| --.net version 1.1.4322.573.
|
| This following error message is now occurring every few seconds in the
| Application event viewer.
| Event ID 1008: The Open Procedure for service "ASP.NET_1.0.3705.6060" in
| DLL "C:\WINNT\Microsoft.NET\Framework\v1.0.3705\aspnet_isapi.dll" failed.

| Performance data for this service will not be available. Status code
| returned is data DWORD 0.
|
| What needs to be done to fix either the error or the software causing it?
|
| Thanks
|
|
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top