Embedding Images in Word 2007



I have a question about an issue with Word 2007.

I made a word document and pasted images into it as usual.

I then saved as a pdf (all in Word 2007) and published the pdf to our website.

When, on our website, I view the pdf and hover over any images, it shows
where it "came from". (meaning my actual computer - which is impossible,
because our office can't be accessed from the web. Also, the images are not
"links" to images. I copied and then pasted into the document.) Similar to:
"c:\david\documents\imagename.gif". We don't want that.

I tried using the "get support" contact form on Microsoft.com but just got
web page with a blank central box. So, I looked on various other forums, and
say many suggestions to do this:

Use the "Office Button", "prepare" and then "edit links to files:.

The only problem with that, is that "edit links to files" isn't there. Just:

- Properties
- Inspect Document
- Encrypt Document
- Restrict Permissions
- Digital Signature
- Mark as Final
- Compatibility Checker

Any ideas how I can remove the "text on hover" from the pdf?

It's not a life or death issue, but it DOES show our internal computer
information TO the internet, which we don't want.
Apparently it's a new "thing" for Office 2007 - and in our previous pdf's we
made with 2003, it's not an issue.

You can see the phenomenon at: http://www.cudamail.com/guide/success.aspx
(the "download the guide" link is to the pdf in question)




Thanks for the reply!

I guess I had my "Microsoft only" blinders on - that would certainly address
the issue.

I think it would also be helpful if there was a solution to the actual "bug"
as well, in case anyone wanted to solve it too.

again, thanks - and I will probably utilize your suggestion.

Jay Freedman

When you drag an image file's icon from a Windows Explorer window and drop
it into a Word document, the file's path is recorded in the picture's Alt
text. You're correct that this is new behavior for Word 2007; it's intended
to make it easier to create documents with accessibility features for
sight-impaired users who use screen-reading software.

To remove the text before saving as PDF, right-click each image, choose
Size, and click the Alt Text tab of the dialog. Select and delete the path.
You might want to replace it with a short description of the image.

I also find that if I display the picture in a program such as IrfanView and
copy/paste it from there, Word doesn't get any Alt text for it.

Jay Freedman
Microsoft Word MVP
Email cannot be acknowledged; please post all follow-ups to the newsgroup so
all may benefit.


Thanks Jay!

That did it.

I never thought to look at a "size" tab to remove alt text. I tried "format
picture", etc, to no avail. You've made my day.


Jay Freedman

I didn't think of the Size dialog at first, either, but I knew there
was an Alt Text setting somewhere. In Word 2003 all of the
picture-related stuff was on mutiple tabs of the Format Picture
dialog. I guess when the MS team was splitting things up to populate
the ribbon, they couldn't think of a good place to put Alt Text so
they stuck it with the nearest neighbor from the old dialog. :-(

Anyway, you're welcome!

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question