Effective Permissions

  • Thread starter Erictyle Dysfunction
  • Start date

Erictyle Dysfunction

I have two PC's with Vista Ultimate. About 4 months ago, on the first PC, I
installed Visual Studio 2005 on it. When I double-click the Icon to run
Visual Studio, it just opens up.

Last week, I installed Vista Ultimate on a new PC. I also installed Visual
Studio on the new PC. When I double-click the Icon to run Visual Studio,
the UAC pops up and says the program needs permission to continue. This is
unusual because I checked "Run as Administrator" and owner is Administrator,
and under the Advanced Security Settings for Visual Studio 2005, the owner
is Administrators, but the funny thing is when I click on the Effective
Permissions tab, the user name is blank. I can click Select to change it,
but the buttons at the bottom of the tab will not allow me to click Apply.
I can click OK, but the settings are not saved.

I think I'm on the right track, but why can't I change the effective


Chad Harris

Hi ED--

It would probably take a committee of psychiatrists and neurologists to
analyze why the UAC team did what they did. They were all made to write
"consistency is the hobgoblin of little minds" Emerson I think on the black
board 1000s of times by their parents. I don't know why your 2nd PC isn't
consistent with your first, or why the run as admin check on setup didn't
prevent this.

Here's how I'd fix things on the second PC--

Right click the VS icon>security tab>add/or edit/type in users>hit the first
checkbox and users will have all permissions fof VS>close>reopne and you
shouldn't see that speed bump message again.

Good luck,


Erictyle Dysfunction

Hi Chad,

Tried what you suggested and it's still a NO GO. Dunno why it doesn't work.
I also clicked on the EXE file and did the same thing.


ED :)

Chad Harris


Sorry I was not thinking correctly--you want to do this to the Visual
Studio Folder, not the shortcut. Go to :\Program Files whatever drive it's
on unless you installed Visual Studio to a different place, and find the
Visual Studio *Folder and then try the moves I mentioned on the Security
tab folder: Right Click>Click Edit buttonAdd>type Users in the object
box>OK> then make sure ck boxes for all permissions are


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question