Different First Page Header but same Footer


W

weircolin

Hi there

I know from the subject line that the easy way to do this is to in the
header and footer box to edit the page setup to have "Different First
Page", however, this doesn't seem to do what I want.

I am setting up a template for minutes so when someone is typing them
they may only have one page, it may be two or three. Now I want it so
there will be a header on the first page only, however, if the minutes
only take the one page there will be a footer on that page, but if
more then the footer will only show on the last page.

I know to do this I use { IF {PAGE} = {NUMPAGES}"""Your Footer Text"}
and that will peform this. However, if I select to have a "Different
First Page" it overrides this and doesn't allow it to work.

I tried using { IF {PAGE} = "1""Header Text"} to keep the header the
same, but it doesn't work. I am trying to put an image in the header
but that shouldn't matter I think.

Can anyone assist me on this please?

Many thanks

Colin
 
Ad

Advertisements

S

Stefan Blom

After you've enabled "Different first page" you have two headers and two
footers. Just add the IF construct to the main footer.
 
S

Suzanne S. Barnhill

It will still work with "Different first page." You just have to put your
field in both the First Page Footer and the Footer.
 
W

weircolin

Hi

Thanks for replies.

I have done that and understand the principal behind it, however, the
footer is still showing on page one and every other page.

Colin
 
S

Stefan Blom

Note that sometimes the absence or presence of spaces in the field code can
be crucial for it to work properly.

{ IF { PAGE } = { NUMPAGES } "Text in last page footer here" }

Also, did you remember to use Ctrl+F9 to add the field delimiters, { }? They
cannot be typed in.
 
W

weircolin

Hi There

Thanks for that. Have been using Ctrl+F9 to do it. Tried spacing as
you said and it then just appeared blank. really at a loss for this
now.

Colin
 
Ad

Advertisements

Ad

Advertisements

S

Suzanne S. Barnhill

The problem was that you had typed the { PAGE } and { NUMPAGE } fields
instead of inserting them as fields. I've emailed the corrected document
back to you.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top