Deploying XP SP3 to Dell Optiplex 760


Jimmy Reb


I am trying to deploy XP SP3 to a Dell Optiplex 760. I have build and
deployed to the Optiplex 745 without any problems. When I boot from the 760
and connect to the Deployment Workbench machine all goes well and the files
are copied across to the Optiplex 760 without any problems. When the 760
reboots and starts to run the XP setup I get past the 'Press F6' for
additional drivers stage and then setup reports that nvrd32.sys cannot be
found and setup canot continue tellin me to reboot. The file is present on
the hard disk in both WIN_NT$.~BT and WIN_NT$.~LS as I have booted WINPE and

If I edit the txtsetup.sif file and remove references to nvrd32.sys then it
goes on to report that cdrom.sys is missing, which is, so I add it manually
and it still doesn't find it.

If I boot the 760 from the XP install CD that it cam with XP setup runs just
fine and it is this that I have used to create the install on the Deployment

I have adding the SATA disk drivers into the Deployment Workbench build so
they get installed during the 'text mode' part of setup but get the same

I really would like some help as I have tried everything I can think of.


Mar 20, 2009
Reaction score
Hi Jim, have you found a solution to this problem? I have the exact same problem with a Dell E6400 laptop, using LANDesk provisioning. Running the install straight from the CD, works fine, but using a provisioning task, it copies the files, and after the reboot, it comes up with the error about nvrd32.sys. I have booted into WinPE and the file exists.

Works fine with XP SP2 CD, but not XP SP3.

Please help! Many thanks, James

Brent Marceaux

Anyone haveAny ideas on this one? I'm having the same exact problem with
other Dell models.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question