Daylight Saving box wont stay checked


G

Guest

I have one computer, running Vista and Outlook 2003 that has a problem with
the shared appointments not showing up right (off by one hour) on the
attendee's calendars when the attendees are experiencing Daylight Saving Time
(ie, now...)

The operating system is set to "Eastern Time GMT -5:00" with "Daylight
Saving Time" check box checked.

When I go into Outlook: Tools -> Options -> Calendar Options -> Time Zone it
shows "Eastern Time GMT - 5:00" but the "Adjust for Daylight Saving Time" is
not checked. I attempt to check it, but it won't stick.

I have done several patches and updates that were supposed to address the
DST issue for both Vista and Office, I have Office 2003 SP3 updated, and I've
attempted to keep that darn box checked every way I know how...but when ever
I open it back up, it is unchecked yet again.

I even read this article with great interest:
http://support.microsoft.com/kb/292893
because it claims to address the issue of the box not staying checked, in
Outlook 2007. The problem is, you can't do what it says to do (click ok three
times) because when you click ok the first time, the dialog closes.

I'd really LOVE a way to get the check box to stay checked, as I think
(hope....pray) this is the answer to this issue, which has been a thorn in
the side for three or four weeks.
 
Ad

Advertisements

D

Diane Poremsky

the 3 ok's are to close the tz dialog, the calendar dialog and the options
dialog...

have you tried disabling dst in windows, setting it in outlook then checking
the windows setting? Are you logged in as Admin? Does it work if outlook run
as administrator?
 
G

Guest

:
oh....now i understand the OKs...but that doesn't seem like much of a
revelation! :)

I've tried it logged in as a user with ADMIN privileges (2 different users)
and tried the "run as administrator" option, as well, thinking that perhaps
there was some permission in the Vista User Account Manager deal that was
causing the issue.

I have tried changing the time zone in windows and trying to get Outlook to
change back or whatever, and that didn't seem to make any difference, in the
main time zone.

I even tried to create a second time zone (which it will create with Eastern
Time and DST marked) and then use the "switch time zones" button, which
promptly causes outlook to uncheck the DST option on my behalf.

Is there maybe a registry entry or something that is causing Outlook to
ignore the system clock setting or somehow automatically ignore all DST?
 
D

Diane Poremsky

I'm not aware of any setting in outlook, visible or hidden, that would tell
it to ignore the DST setting. I'm thinking its something to do with the
wonderful UAC. :) I know there are issues with changing the time and time
zones with it enabled but that wouldn't explain it set in windows but not in
outlook. Do you have the latest updates installed? There is a TZ update
dated late Aug, not that I expect it to make a difference.

Have you tried setting up a profile on a new windows acct? This will tell us
if the profile is just with the window acct or with the whole computer. No
need to do any thing fancy - just a simple profile so you can see if the
setting sticks in it. A new outlook profile in your current windows user
acct probably won't make a difference because I'm pretty sure this setting
is a user acct setting, not a profile setting.
 
G

Guest

I have applied the latest updates for both Outlook/Office 2003 and Vista,
including the Office SP3 and a Vista update regarding DST specifically.

The primary user (Jan) was the account having the problem. I added my
account to the computer and got into Outlook and have the same problem. I
assigned Administrator rights to both Jan and myself. I haven't tried a brand
new "dummy" account, but I could do that if you think it might be helpful. I
also haven't tried logging into Outlook with the local administrator
account...mostly because I don't have an exchange mailbox, etc set up for it,
and the local admin is not technically a domain member...I didn't think it
would work, for testing purposes, though I suppose I could see if the check
box issue was consistent...
 
G

Guest

As an update: I logged into the computer as the local administrator and tried
the two things you suggested:
1) Take "adjust for DST" off the system clock, and then try to apply the
"adjust for DST" option in the TZ dialog on Outlook. When I checked the box,
and clicked ok (three times! :) ) the system clock reset itself to "adjust
for DST" but the TZ dialog, when it was reopened did not have the box checked
again.
2) Obviously, the local admin was a "new" Outlook profile, and was not
interacting with the exchange server or anything, as best I can tell, because
it is not part of the domain. I tried to check the box several times, and
each time it unchecked itself...
 
Ad

Advertisements

D

Diane Poremsky

so just one user is having the problem? That rules out group policies...
since it affects all users on the computer, its not a bad user acct.

Check this setting:
Open GPEDIT.MSC (run as admin)
Under Computer Configuration->Windows Settings->Security Settings->Local
Policies->User Rights Assignment
See if builtin\users has rights to "Change the time zone" - if not or to
test, add Jan's acct.
 
G

Guest

I did as you suggested. The users assigned to "Change the Time Zone" were:
Administrators
LOCAL SERVICE
Users

I added Jan's user (even though she's an Administrator) and tried again.

Same behavior.
 
D

Diane Poremsky

dang. I was sure that would fix it. :(










Eric Wyatt said:
I did as you suggested. The users assigned to "Change the Time Zone" were:
Administrators
LOCAL SERVICE
Users

I added Jan's user (even though she's an Administrator) and tried again.

Same behavior.
 
G

Guest

Forgive me for butting in as I don't have the previous history on what
the exact problem is, but am assuming you cannot keep the "Adjust for
daylight saving time" box checked in Outlook.

I think this is directly linked to the same setting in Date and Time
properties so perhaps there is some permissions issue or policy issue
in your registry that does not manifest itself via the Group Policy
editor.

Look at the following key in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation

and if you see "DisableAutoDaylightTimeSet" set to DWORD 1 then that
is the equivalent of having that box unchecked. Change this to 0 and
see if that helps. If you can't change it due to permissions, then
that's your answer...

If you can change it and it then magically reverts later, search the
registry policy sections for som setting that is causing this.

HTH

Harry
Eric Wyatt said:
I did as you suggested. The users assigned to "Change the Time Zone" were:
Administrators
LOCAL SERVICE
Users

I added Jan's user (even though she's an Administrator) and tried again.

Same behavior.


Ha®®y

(e-mail address removed)
 
D

Diane Poremsky

The problem is that DST is enabled in Vista but its disabled in Outlook -
even though Outlook and the OS should have the same setting and changing it
in one location should change it in the other.

In Vista the key that holds the DST setting is DynamicDaylightTimeDisabled.
 
Ad

Advertisements

G

Guest

Thanks for the info. I'll try it on my Vista machine tomorrow but in
the meantime I wonder if a workaround would be similar: If
DynamicDaylightTimeDisabled is a DWORD of 1 perhaps changing it to 0
will do it....


Diane Poremsky said:
The problem is that DST is enabled in Vista but its disabled in Outlook -
even though Outlook and the OS should have the same setting and changing it
in one location should change it in the other.

In Vista the key that holds the DST setting is DynamicDaylightTimeDisabled.


Ha®®y

(e-mail address removed)
 
Ad

Advertisements

D

Diane Poremsky

This value reflects the setting in windows time and date applet. It should
be 0 if DST is enabled, 1 if disabled. Outlook should read this value and
its DST setting will reflect the values held in this key. It's a system
wide setting so changing the DST setting in either windows or outlook should
reflect when you change it in the other application.

You can certainly try changing it there - if the value is 1, verify DST is
enabled in windows.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top