Data corruption on NTFS 160 GB hard drives in Win2K with VIA or SIS chipsets



I've had data corruption problems when copying large files with
Windows Explorer to/from a large capacity (160 GB) hard drive on 3
different systems with VIA or SIS chipsets, all under Windows 2000 SP3
or SP4 with NTFS partitions. This happens on WD and Maxtor drives.

I've done file byte-compares using Windiff or DOS file compare (fc),
and it's usually only a dozen or so consecutive bytes that get
corrupted every 10+ GBs I copy, so it's hard to notice the problem
unless I run Windiff afterwards. I've never seen the problem when
copying files under 1 GB in size, and it's so intermittent that
sometimes I can copy a 10 GB file several times before I see the
problem, but it always happens at some point.

I had this problem on 2 Shuttle MV42N (VIA chipset) systems, and I
installed the latest VIA 4-in-1 drivers with no success. On one system
I reinstalled Windows 2000 from scratch without installing the VIA
4-in-1 drivers, and it solved the problem. But when I did the same
reinstall on the other system with the same motherboard, the data
corruption problem was still there. I got frustrated and replaced the
160 GB with a 120 GB HD on that system... and no more problems, but I
hate being beaten by this problem.

I then moved the 160 GB HD to an existing working Windows 2000 install
on a ECS K7S5A system (SIS chipset) with a 120 GB HD thinking I'd be
safe on a motherboard without VIA chipsets. Wrong! First I had to
install WD's utilities to enable the full capacity of the 160 GB HD.
Now I can copy big files all day on the WD 120 GB HD and never see any
corruption, but as soon as I go to or from the WD 160 GB HD, I get the
intermittent data corruption quite often. I then bought a 3rd 160 GB
HD thinking maybe this one was defective, and the 3rd HD has the same

Because I've been bitten by this 3 times on 3 different systems, I'm
convinced there is a bad EIDE driver or buffer/cache problem in
Windows 2000 when copying large files on HDs beyond the normal 137 GB
limit. Has anyone else seen or solved this problem?

I searched Usenet and saw various old posts blaming the VIA chipset
(which doesn't explain why I see it on the SIS chipset) or suggesting
a "PCI latency patch". Unfortunately I never could locate this patch,
and the links others posted to it were no longer valid. I'm using the
motherboard's built-in EIDE controllers, but I once tried going
through a Maxtor UDMA/ATA 133 PCI card on the VIA chipset system and
had the same problem either way.

The 2 motherboards I see this problem on are:
Shuttle MV42N - VIA 8751 (P4M266) NB and VIA 8233 SB
ECS K7S5A (BIOS 10/29/02) - SIS 735

Any ideas or suggestions? I'd really appreciate the help. Thanks.

Alexander Grigoriev

For testing I/O corruption issues,

If you see corruption while copying from one drive to another, connected to
different IDE channels, this is likely old VIA problem. If you have only one
drive, or drives connected to one channel, the corruption is somewhere in
transit, but still could be related to the same problem (DMA FIFO not

What are last bits of the difference file offset? are the different bytes in
the end of a page or a sector?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question