Cryptographic Service Error 127

Discussion in 'Windows XP General' started by Guest, Jan 25, 2005.

  1. Guest

    Guest Guest

    I have recently tried to install Service Pack 2 as well as other Windows
    updates. When doing this, I get an error about the Cryptographic Service not
    being started. I go into the services panel, and I try to start the service.
    However, I get this error:

    "Services"
    Could not start the Cryptographic Services service on Local Computer.
    Error 127: The specified procedure could not be found.

    I have had this for about four to five days, and I have tried the updatexp
    article, and nothing worked. (The article does not even talk about error
    127.) So, my questions are:

    1. Is there any way to reinstall just a windows service?
    2. If not, how will I fix this?
    3. Will I have to reinstall windows?
     
    Guest, Jan 25, 2005
    #1
    1. Advertisements

  2. Jupiter Jones [MVP], Jan 25, 2005
    #2
    1. Advertisements

  3. Guest

    Alex Nichol Guest

    This is probably not actually the cryptographic service at all (you can
    check that is started at Admin Tools - Services)

    Go to C:\Windows\system32 and rename the folder catroot2 - say to
    catroot2old Then reboot for a new one to be made; the SP install should
    now work
     
    Alex Nichol, Jan 26, 2005
    #3
  4. Guest

    Guest Guest

    I have dealt with the catroot folder and the unregistering/registering of the
    DLL files. The service still gives me this error when I try to start it...
     
    Guest, Jan 26, 2005
    #4
  5. Hi

    See if this helps:

    Go to
    http://www.michna.com/kb/WxSP2.htm#Cannot_install_Service_Pack_2

    Look for fixdb.bat under "Error 0x800710D9 Unable to read from
    or write to the database". Download and run it.
     
    Torgeir Bakken \(MVP\), Jan 27, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.