Connecting Mac OS X to Win 2000 Server


C

Chris Raffle

We are in the process of setting up a Windows 2000 server and one of
things I am having trouble with is getting a Mac OS X to connect to
the network server.

I have the file and printer services for Macintosh enabled and I have
gone into Start > Programs > Administrative Tools > Computer
Management > System Tools > Shared Folders, right clicked and selected
the option to 'Configure File Server for Macintosh' and gave it a
name.

There is a Microsoft UAM Volume listed under the Shared Folders >
Shares directory in the Comp Mgmt console. When I go to the OS X, I go
to 'Connect to server' and input smb://ip address/share name, and I
receive a prompt for a user name, password & domain.

The login on the OS X machine is identical to the Windows 2000 login
for that user and I specify that information at this login prompt.
However, once I enter that in, I eventually either receive an error
message stating "An error has occurred (error = -36)," or, very
rarely, I receive a fatal error message that requires me to restart
the Mac.

On the Win 2K server, under the properties for the Ethernet adapter, I
have an AppleTalk Protocol installed. Now, this is where I wonder if I
made an error, because under the properties for that protocol I
checked the box to accept inbound connections on this adapter. When I
checked this box, I received an message stating that there was another
service/component using that setting and that service/component would
stop in order to enable it on the AppleTalk protocol. I don't remember
the exact wording but I believe it was something to that effect. I did
not have an option to cancel this and now I cannot uncheck the box.

I tried uninstalling the AppleTalk protocol but I received an error
message that I must disconnect all dial-up, VPN, and incoming
connections before the component can be removed. Since the server is
not in a production environment, I tried disabling the ethernet
adapter so that I could uninstall it and I still received the same
error message. I also tried removing the file and printer services for
Macintosh to see if that would remove the protocol along with it but
that did not work.

I'm not sure if this is the reason for my problem, but if anyone can
provide any thoughts or suggestions, I would greatly appreciate it.
 
Ad

Advertisements

C

Christopher Udy

OS X can connect to a Win2K server without using the Services for Macintosh.

From the Finder's 'Go' Menu
Select Connect to Server
If you have Jaguar (OS X 10.2) you will see a list of available
servers/workgroups/domains
In the address textbox enter smb://serverIPaddress/sharename
for my network, I use smb://192.168.0.144/f

HTH
Chris
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top